Bug 142930 - Boot and mt hangs due to SCSI tape drive
Boot and mt hangs due to SCSI tape drive
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 20:25 EST by Jørgen Thomsen
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jørgen Thomsen 2004-12-14 20:25:26 EST
From Bugzilla Helper:
User-Agent: Opera/7.54 (Windows NT 5.1; U)  [en]

Description of problem:
After moving a well functioning HP C1533A 4/8 GB SCSI tape drive from 
a Redhat 8 machine to this one, booting is impossible. It stalls in 
Initializing hardware... (ctrl-alt-del + ctrl-c makes it reboot and 
end up the same place)

Once I managed to make it boot, and ran a mt -f /dev/st0 status. 
Output was normal, but mt never returned and was impossible to kill.

Logs are showing no errors.

When there is no power on the drive, there is no problem.

Version-Release number of selected component (if applicable):
2.6.9-1.667 + -2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

SCSI subsystem initialized
ACPI: PCI interrupt 0000:01:07.0[A] -> GSI 11 (level, low) -> IRQ 11
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
        <Adaptec 2940 SCSI adapter>
        aic7870: Wide Channel A, SCSI Id=15, 16/253 SCBs

libata version 1.02 loaded.
sata_sil version 0.54
ACPI: PCI interrupt 0000:01:0b.0[A] -> GSI 11 (level, low) -> IRQ 11
ata1: SATA max UDMA/100 cmd 0x22832080 ctl 0x2283208A bmdma 
0x22832000 irq 11
ata2: SATA max UDMA/100 cmd 0x228320C0 ctl 0x228320CA bmdma 
0x22832008 irq 11
Comment 1 Jørgen Thomsen 2004-12-14 20:27:37 EST
The tape drive is of course recognized by the Adaptec adapter (I 
tried another adapter, too)
Comment 2 Jørgen Thomsen 2004-12-18 22:20:19 EST
Good news. 
Adaptec SCSI controller no. 3 was working. After a firmware upgrade 
of the tape drive Adaptec SCSI controller no. 2 was also working. 
However Adaptec SCSI controller no. 1 still doesn't work. As so often 
SCSI termination could be the culprit, but experiments with different 
combinations of termination did not change the pattern. It appears to 
be primarily a hardware/firmware problem.
 
However mt should always return, and booting should not be prevented, 
so a little more error resistence should be incorporated. A hardware 
defect in a non-critical peripheral should not have serious impact on 
the whole system. I definitely would want my server to boot and live 
with a bad tape drive for a while.
Comment 3 Dave Jones 2005-07-15 14:12:11 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Dave Jones 2005-10-02 20:40:27 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.