Bug 142942 - cant print names and values of selected locale keyword
Summary: cant print names and values of selected locale keyword
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: RHEL4-LI18NUX
TreeView+ depends on / blocked
 
Reported: 2004-12-15 07:36 UTC by Lawrence Lim
Modified: 2016-11-24 12:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 09:25:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script with a single Test Case from LI18NUX Test (13.38 KB, application/octet-stream)
2004-12-15 07:38 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-12-15 07:36:58 UTC
Description of problem:
This bug is filed as it is one of the errors reported in the LI18nUX
test suite, part of the LSB conformance test.

I have stripped down the test suite to only the single test case. I
would really appreciate if you could have a look and let me know if
this is a glibc error or Test Case issue?

Version-Release number of selected component (if applicable):
glibc-devel-2.3.3-86
glibc-profile-2.3.3-86
glibc-headers-2.3.3-86
compat-glibc-headers-2.3.2-95.30
glibc-2.3.3-86
glibc-kernheaders-2.4-9.1.87
compat-glibc-2.3.2-95.30
glibc-common-2.3.3-86
glibc-utils-2.3.3-86

How reproducible:
Always

Steps to Reproduce:
1.Down the attachment, locale.tar.gz
2.run ./locale.sh
3.view the result in the output file, tet_xres
  
Actual results:
ctype-class-offset=71 should be ctype-class-offset=70
ctype-map-offset=90 should be ctype-map-offset=89
Can't print names and values of selected locale keyword.

Expected results:
When -k option is specified, this utility writes the names and values
of selected keywords

Additional info:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=108593&action=view

Comment 1 Lawrence Lim 2004-12-15 07:38:53 UTC
Created attachment 108594 [details]
script with a single Test Case from LI18NUX Test

Comment 2 Jakub Jelinek 2004-12-15 09:25:29 UTC
Testsuite bug, here is what I posted in my analysis of LSB 1.3 failures:
520|553 6 22710 1 1|* When -k option is specified, verify if this utility writes the names and values of selected keywords.
520|553 6 22710 1 2|
520|553 6 22710 1 3|ctype-class-offset=71 should be ctype-class-offset=70
520|553 6 22710 1 4|ctype-map-offset=90 should be ctype-map-offset=89
520|553 6 22710 1 5|Can't print names and values of selected locale keyword.
220|553 6 1 00:21:07|FAIL

This was increased because of the addition of _NL_CTYPE_MAP_TO_NONASCII
I'd say the LSB testsuite has no business testing these values, these values
are in no way useful for applications and are implementation detail.
These values are no longer tested in LSB 2.0.




Note You need to log in before you can comment on or make changes to this bug.