Bug 1429430 - Should remove --dcpath and --dcPath options in virt-v2v help info
Summary: Should remove --dcpath and --dcPath options in virt-v2v help info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.4
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-06 11:22 UTC by mxie@redhat.com
Modified: 2017-08-01 22:13 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.36.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:13:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description mxie@redhat.com 2017-03-06 11:22:02 UTC
Description of problem:
Should remove --dcpath and --dcPath options in virt-v2v help info

Version-Release number of selected component (if applicable):
virt-v2v-1.36.1-1.el7.x86_64
libguestfs-1.36.1-1.el7.x86_64



How reproducible:
100%

Steps to Reproduce:
1.Check virt-v2v man page and there is no info about--dcpath and--dcPath
# man virt-v2v |grep dcpath
nothing
# man virt-v2v |grep dcPath
nothing

2.Check virt-v2v help info but there is info about --dcpath and--dcPath
# virt-v2v --help
....
--dcpath, --dcPath <path>           Override dcPath (for vCenter)
....

Actual results:
As above description

Expected results:
Should remove --dcpath and --dcPath options in virt-v2v help info

Addtional info:

Comment 2 Richard W.M. Jones 2017-03-06 11:41:30 UTC
We should hide the options upstream as well as in RHEL.

Comment 4 kuwei@redhat.com 2017-03-09 09:02:13 UTC
I can reproduce the bug with below builds:
virt-v2v-1.36.1-1.el7.x86_64
libguestfs-1.36.1-1.el7.x86_64

Verify it with below builds:
virt-v2v-1.36.2-1.el7.x86_64
libguestfs-1.36.2-1.el7.x86_64


Verify steps:
1.Check --dcpath and--dcPath  in virt-v2v man page and there is no info.
# man virt-v2v |grep dcpath
nothing
# man virt-v2v |grep dcPath
nothing

2.Check  --dcpath and--dcPath in  virt-v2v help info .
# virt-v2v --help | grep dcpath
Nothing
#virt-v2v --help | grep dcPath
Nothing

So,--dcpath and --dcPath options has not  in virt-v2v help info

So move the bug from ON_QA to VERIFIED

Comment 5 errata-xmlrpc 2017-08-01 22:13:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.