Bug 1429432 (CVE-2017-6505) - CVE-2017-6505 Qemu: usb: an infinite loop issue in ohci_service_ed_list
Summary: CVE-2017-6505 Qemu: usb: an infinite loop issue in ohci_service_ed_list
Status: CLOSED WONTFIX
Alias: CVE-2017-6505
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170207,reported=2...
Keywords: Security
Depends On: 1429433 1429434
Blocks: 1425735
TreeView+ depends on / blocked
 
Reported: 2017-03-06 11:26 UTC by Prasad J Pandit
Modified: 2019-06-08 21:50 UTC (History)
37 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-08 03:08:24 UTC


Attachments (Terms of Use)

Description Prasad J Pandit 2017-03-06 11:26:16 UTC
Quick Emulator built with the USB OHCI Emulation support is vulnerable to an
infinite loop issue. It could occur while processing an endpoint list
descriptor in ohci_service_ed_list().

A guest user/process could use this flaw to crash Qemu process resulting in DoS.

Upstream patch:
---------------
  -> http://git.qemu-project.org/?p=qemu.git;a=commitdiff;h=95ed56939eb2eaa4e2f349fe6dcd13ca4edfd8fb

Reference:
----------
  -> http://www.openwall.com/lists/oss-security/2017/03/06/6

Comment 1 Prasad J Pandit 2017-03-06 11:26:50 UTC
Acknowledgments:

Name: Li Qiang (360.cn Inc.)

Comment 2 Prasad J Pandit 2017-03-06 11:29:51 UTC
Created xen tracking bugs for this issue:

Affects: fedora-all [bug 1429433]

Comment 3 Prasad J Pandit 2017-03-06 11:30:14 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1429434]


Note You need to log in before you can comment on or make changes to this bug.