Bug 1429465 - Tempest init throwing traceback on latest RHOS11 puddle due to Octavia Tempest plugin bug
Summary: Tempest init throwing traceback on latest RHOS11 puddle due to Octavia Tempes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Nir Magnezi
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-06 12:37 UTC by Anshul Behl
Modified: 2019-09-10 14:11 UTC (History)
16 users (show)

Fixed In Version: openstack-octavia-0.10.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:05:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 455260 None None None 2017-04-10 18:01:21 UTC
OpenStack gerrit 455405 None None None 2017-04-10 18:02:18 UTC
Launchpad 1681405 None None None 2017-04-10 18:00:27 UTC

Description Anshul Behl 2017-03-06 12:37:41 UTC
Description of problem:
After installing the latest puddle via packstack and running tempest I am running into tracebacks from tempest init

Version-Release number of selected component (if applicable):
2017-03-01.1
RHOS11 puddle

How reproducible:
Everytime

Steps to Reproduce:
1. Do a packstack all in one installation
2. Install openstack-tempest-all package
3. Run tempest init <DIR>

Actual results:
[stack@localhost ~(keystone_admin)]$ tempest init foobar --debug
2017-03-06 18:02:36.275 18133 INFO tempest [-] Using tempest config file /etc/tempest/tempest.conf
2017-03-06 18:02:36.427 18133 WARNING stevedore.named [-] Could not load oslo.i18n, oslo.serialization, oslo.utils
2017-03-06 18:02:36.429 18133 ERROR tempest [-] 'tuple' object has no attribute 'dest'
2017-03-06 18:02:36.429 18133 ERROR tempest Traceback (most recent call last):
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/cliff/app.py", line 400, in run_subcommand
2017-03-06 18:02:36.429 18133 ERROR tempest     result = cmd.run(parsed_args)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/cliff/command.py", line 90, in run
2017-03-06 18:02:36.429 18133 ERROR tempest     return self.take_action(parsed_args) or 0
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 181, in take_action
2017-03-06 18:02:36.429 18133 ERROR tempest     self.create_working_dir(parsed_args.dir, config_dir)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 163, in create_working_dir
2017-03-06 18:02:36.429 18133 ERROR tempest     self.generate_sample_config(local_dir)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 131, in generate_sample_config
2017-03-06 18:02:36.429 18133 ERROR tempest     output_file])
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 526, in main
2017-03-06 18:02:36.429 18133 ERROR tempest     generate(conf)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 506, in generate
2017-03-06 18:02:36.429 18133 ERROR tempest     groups = _get_groups(_list_opts(conf.namespace))
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 432, in _list_opts
2017-03-06 18:02:36.429 18133 ERROR tempest     return _cleanup_opts(opts)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 370, in _cleanup_opts
2017-03-06 18:02:36.429 18133 ERROR tempest     clean[namespace][group][opt.dest] = opt
2017-03-06 18:02:36.429 18133 ERROR tempest AttributeError: 'tuple' object has no attribute 'dest'
2017-03-06 18:02:36.429 18133 ERROR tempest 
2017-03-06 18:02:36.429 18133 CRITICAL tempest [-] AttributeError: 'tuple' object has no attribute 'dest'
2017-03-06 18:02:36.429 18133 ERROR tempest Traceback (most recent call last):
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/bin/tempest", line 10, in <module>
2017-03-06 18:02:36.429 18133 ERROR tempest     sys.exit(main())
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/main.py", line 48, in main
2017-03-06 18:02:36.429 18133 ERROR tempest     return the_app.run(argv)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/cliff/app.py", line 279, in run
2017-03-06 18:02:36.429 18133 ERROR tempest     result = self.run_subcommand(remainder)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/cliff/app.py", line 400, in run_subcommand
2017-03-06 18:02:36.429 18133 ERROR tempest     result = cmd.run(parsed_args)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/cliff/command.py", line 90, in run
2017-03-06 18:02:36.429 18133 ERROR tempest     return self.take_action(parsed_args) or 0
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 181, in take_action
2017-03-06 18:02:36.429 18133 ERROR tempest     self.create_working_dir(parsed_args.dir, config_dir)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 163, in create_working_dir
2017-03-06 18:02:36.429 18133 ERROR tempest     self.generate_sample_config(local_dir)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/tempest/cmd/init.py", line 131, in generate_sample_config
2017-03-06 18:02:36.429 18133 ERROR tempest     output_file])
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 526, in main
2017-03-06 18:02:36.429 18133 ERROR tempest     generate(conf)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 506, in generate
2017-03-06 18:02:36.429 18133 ERROR tempest     groups = _get_groups(_list_opts(conf.namespace))
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 432, in _list_opts
2017-03-06 18:02:36.429 18133 ERROR tempest     return _cleanup_opts(opts)
2017-03-06 18:02:36.429 18133 ERROR tempest   File "/usr/lib/python2.7/site-packages/oslo_config/generator.py", line 370, in _cleanup_opts
2017-03-06 18:02:36.429 18133 ERROR tempest     clean[namespace][group][opt.dest] = opt
2017-03-06 18:02:36.429 18133 ERROR tempest AttributeError: 'tuple' object has no attribute 'dest'
2017-03-06 18:02:36.429 18133 ERROR tempest 


Expected results:
No Traceback

Comment 1 Anshul Behl 2017-03-06 13:33:00 UTC
This works fine if I don't install openstack-tempest-all, however we will have to check which tempest plugin is exactly causing the above issue.

Comment 2 David Sariel 2017-03-30 08:46:39 UTC
I tried without openstack-tempest-all and it desn't work for me. Is there an ETA?

Comment 3 Martin Kopec 2017-04-05 15:51:08 UTC
I seems it could be related to python-octavia-tests package. When the package was removed, tempest init finished without a traceback.

Comment 4 Chandan Kumar 2017-04-10 18:06:01 UTC
Based on investigation, we found that tempest init cli is failing due to extra comma and wrong method used in python-octavia-tests (Octavia tempest plugin).
Here is the upstream bug: https://bugs.launchpad.net/octavia/+bug/1681405 and related fix https://review.openstack.org/455260 is already merged in master and here is the stable/ocata backport patch: https://review.openstack.org/455405.
So changing the component from openstack-tempest to openstack-octavia.

Comment 5 Assaf Muller 2017-04-18 14:44:58 UTC
According to the bug description we cannot currently run Tempest. The fix has already been merged in stable/ocata, the next step is to cherry pick to OSP 11.

Comment 6 Assaf Muller 2017-04-18 15:49:30 UTC
I don't see https://review.openstack.org/#/c/455405/ in any RPM we ship in any puddle. Looks like we'll need to cherry pick. This issue was reported in March and is still not fixed in latest puddles, can you please find out what is the scope of the issue? When does the issue manifest?

Comment 7 Nir Magnezi 2017-04-19 20:25:30 UTC
(In reply to Assaf Muller from comment #6)
> I don't see https://review.openstack.org/#/c/455405/ in any RPM we ship in
> any puddle. Looks like we'll need to cherry pick. This issue was reported in
> March and is still not fixed in latest puddles, can you please find out what
> is the scope of the issue? When does the issue manifest?

Yes.
I cherry-picked it to see how CI behaves.
I will also try to manually reproduce comment #0 and apply the fix to verify this is indeed the patch that resolves the issue.

Comment 10 Nir Magnezi 2017-04-20 16:31:13 UTC
Hi Anshul,

Could you please try to use this[1] package and report?

[1] https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=552120

Comment 12 Assaf Muller 2017-04-21 14:19:55 UTC
Latest package on Brew has a fix for this patch, it was rebased in.

Comment 13 Assaf Muller 2017-04-21 14:22:28 UTC
Fix is already in, flags not relevant anymore.

Comment 15 Anshul Behl 2017-04-24 09:08:03 UTC
Checked with

# rpm -qa | grep openstack-tempest
openstack-tempest-15.0.0-2.el7ost.noarch
openstack-tempest-all-15.0.0-2.el7ost.noarch
# rpm -qa | grep octavia
python-octavia-0.10.0-6.el7ost.noarch
python-octavia-tests-0.10.0-6.el7ost.noarch


Works fine, bug can be verified.

Thanks,
Anshul Behl

Comment 16 Nir Magnezi 2017-04-24 09:15:15 UTC
Thanks Anshul

Comment 19 Alexander Stafeyev 2017-05-10 04:57:40 UTC
Hi Anshul, 
Do you have an option to verify this one with the same steps you saw this bug?

BR

Comment 20 Anshul Behl 2017-05-10 09:51:46 UTC
Hi Alexander,

I think this has been verified already by me, you can mark it as done accordingly.

BR

Comment 21 Alexander Stafeyev 2017-05-10 13:16:39 UTC
(In reply to Anshul Behl from comment #20)
> Hi Alexander,
> 
> I think this has been verified already by me, you can mark it as done
> accordingly.
> 
> BR

Verified by  Anshul Behl 

tnx

Comment 22 errata-xmlrpc 2017-05-17 20:05:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.