Bug 1429491 - Should rename network name of rhv in virt-v2v man page
Summary: Should rename network name of rhv in virt-v2v man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.4
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-06 13:39 UTC by mxie@redhat.com
Modified: 2017-08-01 22:13 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.36.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:13:55 UTC


Attachments (Terms of Use)
screenshot (25.65 KB, image/png)
2017-03-06 13:39 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description mxie@redhat.com 2017-03-06 13:39:15 UTC
Created attachment 1260408 [details]
screenshot

Description of problem:
Should rename network name of rhv in virt-v2v man page

Version-Release number of selected component (if applicable):
virt-v2v-1.36.1-1.el7.x86_64
libguestfs-1.36.1-1.el7.x86_64
RHVM: 4.1.1.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1.Check the network name of rhv in virt-v2v man page
# man virt-v2v |grep rhvm
-o rhv -os rhv.nfs:/export_domain --network rhvm
Guest network interface(s) are connected to the target network called "rhvm".
-o rhv -os rhv.nfs:/export_domain --network rhvm
To map a specific network to a target network, for example "default" on the source to "rhvm" on the
        virt-v2v [...] --network default:rhvm
        virt-v2v [...] --network rhvm

2.Because the network name of rhvm has been changed to ovirtmgmt since rhvm3.6.10,pls refer to screenshot, so need to update the network name of rhv  from rhvm to ovirtmgmt in virt-v2v man page 

Actual results:
As above description

Expected results:
Change network name of rhv from rhvm to ovirtmgmt in virt-v2v man page

Additional info:

Comment 2 Pino Toscano 2017-03-06 15:08:08 UTC
Patch posted:
  https://www.redhat.com/archives/libguestfs/2017-March/msg00085.html

Comment 5 mxie@redhat.com 2017-03-09 06:16:03 UTC
Verify the bug with builds:
virt-v2v-1.36.2-1.el7.x86_64
libguestfs-1.36.2-1.el7.x86_64


Steps:
1.Check the network name of rhv in virt-v2v man page
# man virt-v2v |grep rhvm
nothing

# man virt-v2v |grep ovirtmgmt
          -o rhv -os rhv.nfs:/export_domain --network ovirtmgmt
       Guest network interface(s) are connected to the target network called "ovirtmgmt".
          -o rhv -os rhv.nfs:/export_domain --network ovirtmgmt
       To map a specific network to a target network, for example "default" on the source to "ovirtmgmt" on
        virt-v2v [...] --network default:ovirtmgmt
        virt-v2v [...] --network ovirtmgmt

According to above result, virt-v2v man page has changed network name of rhv from rhvm to ovirtmgmt , the bug has been fixed 


So move the bug from ON_QA to VERIFIED

Comment 6 errata-xmlrpc 2017-08-01 22:13:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.