Bug 142956 - /usr/sbin/warnquota displays block limits all run together if 8 digits or over
/usr/sbin/warnquota displays block limits all run together if 8 digits or over
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: quota (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Amit Gud
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-15 07:24 EST by Steven Young
Modified: 2014-09-23 02:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: quota-tools-3.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-28 12:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch file for warnquota.c (923 bytes, patch)
2004-12-15 07:28 EST, Steven Young
no flags Details | Diff

  None (edit)
Description Steven Young 2004-12-15 07:24:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
When quota limits are above 10G, then when warnquota is used to
provide user quota warning by email, the reported block limits all run
together.

Ie:
                        Block limits               File limits
Filesystem           used    soft    hard  grace    used  soft  hard 
grace
/dev/sda1      +-259749082097152031457280  6days     967     0     0     



Version-Release number of selected component (if applicable):
quota-3.09-1

How reproducible:
Always

Steps to Reproduce:
1. Set up a user's quota with soft and hard limits above 10000000 (ie
8 digits).
2. Make the user's usage go above their soft limit
3. Run /usr/sbin/warnquota and examine the email output.
    

Actual Results:  The reported block limit values all run together and
are difficult to read.

Expected Results:  There should be (at least) a space between the
block limit values.

Additional info:

This problem looks like it is fixed in release quota-3.12.
Comment 1 Steven Young 2004-12-15 07:28:31 EST
Created attachment 108605 [details]
A patch file for warnquota.c

I've included this patch in an appropriate RPM spec to build a version of
warnquota that I want to use.

Note You need to log in before you can comment on or make changes to this bug.