Bug 14296 - Floppy icon will not mount LS120 Drive
Floppy icon will not mount LS120 Drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-19 15:54 EDT by Mick Tantasirikorn
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 16:24:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mick Tantasirikorn 2000-07-19 15:54:20 EDT
in either KDE or Gnome the floppy icon will not correctly mount the ls120.

"If you use a regular floppy drive :
Gnome: double clicking on the Floppy icon you get "/dev/fd0: Input/Output 
error" warning box, but the drive is mounted buy you don't get file 
manager window.
KDE: clicking on the floppy ifon you get "The desktop entry 
file /root/Desktop/Floppy Device is of type FSDevice but has no 
Dev=...entry", and the drive is not mounted." <I will report this error in 
a different bug# but I put it here as an info.>

gnome and kde floppy icons points to /dev/fd0 so it does not work.
However, if you mount the drive to /mnt/floppy first, the icons will work, 
but if you mount it elsewhere it will not.

there is no entry in /etc/fstab regarding the hdc
/dev/hda5               /                       ext2    defaults        1 1
/dev/hda1               /boot                   ext2    defaults        1 2
/dev/hda7               /home                   ext2    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/hda6               swap                    swap    defaults        0 0

and here is the df -h output after mounting 
using "mount /dev/hdc /mnt/ls120"

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda5             2.9G  2.1G  750M  74% /
/dev/hda1              23M  2.4M   19M  11% /boot
/dev/hda7             2.5G   20k  2.3G   1% /home
/dev/hdc              1.4M 1020k  403k  72% /mnt/ls120
Comment 1 Dan Taylor 2000-08-23 16:24:38 EDT
This seems to be working better in RC2 with GNOME.  The ls120 is being added to 
the /etc/fstab and in GNOME there is a 'Device 0' icon showing on the desktop 
that mounts the drive & makes it accessible.

However KDE still fails.  There is only a floppy & a cdrom icon showing up on 
the desktop, neither of which work when there is an ls120 in the bay.  Should 
this be moved over as a KDE issue?
Comment 2 Bernhard Rosenkraenzer 2000-08-30 09:10:23 EDT
This should be fixed in 7.0. Don't have the hardware to verify it though.

Note You need to log in before you can comment on or make changes to this bug.