Bug 1429674 - Openstack Undercloud install tries to remove firewalld and fails
Summary: Openstack Undercloud install tries to remove firewalld and fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: All
OS: Linux
high
high
Target Milestone: beta
: 11.0 (Ocata)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1418295
TreeView+ depends on / blocked
 
Reported: 2017-03-06 20:04 UTC by Alex Schultz
Modified: 2018-03-07 10:49 UTC (History)
13 users (show)

Fixed In Version: instack-undercloud-6.0.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1418295
Environment:
Last Closed: 2017-05-17 20:05:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 442143 None None None 2017-03-06 20:04:18 UTC
OpenStack gerrit 443680 None None None 2017-03-09 15:08:00 UTC
Launchpad 1669915 None None None 2017-03-06 20:04:18 UTC

Description Alex Schultz 2017-03-06 20:04:18 UTC
+++ This bug was initially created as a clone of Bug #1418295 +++

Description of problem:

During installation of Undercloud, if firewalld rpm is found, the Installer tries to remove firewalld and fails because of firewalld dependencies

Version-Release number of selected component (if applicable): RHOS10


How reproducible: Installation of RHOS 10 undercloud using official repo present in official Documentation


Steps to Reproduce:
1. Register the Undercloud using subscription-manager
2. run the command by stack user: $ sudo yum install -y python-tripleoclient
3. $ cp /usr/share/instack-undercloud/undercloud.conf.sample ~/undercloud.conf
4. $ openstack undercloud install

Actual results:

Failed installation with error 

2017-02-01 15:26:41,112 INFO: 2017-02-01 15:26:41 - Error: Execution of '/bin/rpm -e firewalld-0.4.3.2-8.1.el7_3.noarch' returned 1: error: Failed dependencies:
2017-02-01 15:26:41,112 INFO: 2017-02-01 15:26:41 - 	firewalld >= 0.3.5-1 is needed by (installed) anaconda-core-21.48.22.93-1.el7.x86_64
2017-02-01 15:26:41,113 INFO: 2017-02-01 15:26:41 - 	firewalld = 0.4.3.2-8.1.el7_3 is needed by (installed) firewall-config-0.4.3.2-8.1.el7_3.noarch
2017-02-01 15:26:41,113 INFO: 2017-02-01 15:26:41 - Error: /Stage[main]/Main/Package[firewalld]/ensure: change from 0.4.3.2-8.1.el7_3 to absent failed: Execution of '/bin/rpm -e firewalld-0.4.3.2-8.1.el7_3.noarch' returned 1: error: Failed dependencies:
2017-02-01 15:26:41,113 INFO: 2017-02-01 15:26:41 - 	firewalld >= 0.3.5-1 is needed by (installed) anaconda-core-21.48.22.93-1.el7.x86_64
2017-02-01 15:26:41,114 INFO: 2017-02-01 15:26:41 - 	firewalld = 0.4.3.2-8.1.el7_3 is needed by (installed) firewall-config-0.4.3.2-8.1.el7_3.noarch


2017-02-01 16:05:17,204 INFO: 2017-02-01 16:05:17 - Warning: /Firewall[998 log all]: Skipping because of failed dependencies
2017-02-01 16:05:17,236 INFO: 2017-02-01 16:05:17 - Notice: /Firewall[999 drop all]: Dependency Package[firewalld] has failures: true
2017-02-01 16:05:17,256 INFO: 2017-02-01 16:05:17 - Warning: /Firewall[999 drop all]: Skipping because of failed dependencies
2017-02-01 16:05:18,939 INFO: 2017-02-01 16:05:18 - Notice: Finished catalog run in 2422.20 seconds
2017-02-01 16:05:43,224 INFO: + rc=6
2017-02-01 16:05:43,252 INFO: + set -e
2017-02-01 16:05:43,256 INFO: + echo 'puppet apply exited with exit code 6'
2017-02-01 16:05:43,257 INFO: puppet apply exited with exit code 6
2017-02-01 16:05:43,263 INFO: + '[' 6 '!=' 2 -a 6 '!=' 0 ']'
2017-02-01 16:05:43,263 INFO: + exit 6
2017-02-01 16:05:43,638 INFO: [2017-02-01 16:05:43,611] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2017-02-01 16:05:43,642 INFO: 
2017-02-01 16:05:43,651 INFO: [2017-02-01 16:05:43,643] (os-refresh-config) [ERROR] Aborting...



Expected results:

The Undercloud install should be seamless and should be completed successfully

Additional info:

--- Additional comment from Igal Katzir on 2017-02-07 08:31:29 EST ---

I am getting the same error on my system with the same scenario:
2017-02-07 15:19:29,420 INFO: 2017-02-07 15:19:29 - Notice: /Firewall[998 log all]: Dependency Package[firewalld] has failures: true
2017-02-07 15:19:29,423 INFO: 2017-02-07 15:19:29 - Warning: /Firewall[998 log all]: Skipping because of failed dependencies
2017-02-07 15:19:29,443 INFO: 2017-02-07 15:19:29 - Notice: /Firewall[999 drop all]: Dependency Package[firewalld] has failures: true
2017-02-07 15:19:29,448 INFO: 2017-02-07 15:19:29 - Warning: /Firewall[999 drop all]: Skipping because of failed dependencies
2017-02-07 15:19:31,020 INFO: 2017-02-07 15:19:31 - Notice: Finished catalog run in 409.89 seconds
2017-02-07 15:19:36,286 INFO: + rc=6
2017-02-07 15:19:36,286 INFO: + set -e
2017-02-07 15:19:36,287 INFO: + echo 'puppet apply exited with exit code 6'
2017-02-07 15:19:36,287 INFO: puppet apply exited with exit code 6
2017-02-07 15:19:36,287 INFO: + '[' 6 '!=' 2 -a 6 '!=' 0 ']'
2017-02-07 15:19:36,287 INFO: + exit 6
2017-02-07 15:19:36,287 INFO: [2017-02-07 15:19:36,287] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2017-02-07 15:19:36,287 INFO:
2017-02-07 15:19:36,288 INFO: [2017-02-07 15:19:36,287] (os-refresh-config) [ERROR] Aborting...

--- Additional comment from Andrew Ludwar on 2017-02-10 13:22:31 EST ---

firewalld is intentionally removed during undercloud install:

/usr/share/instack-undercloud/puppet-stack-config/puppet-stack-config.pp
...
508 ensure_resource('package', 'firewalld', {
509   'ensure' => 'absent',
510 })
...

Looks like there's a dependency issue introduced when a system is installed graphically (as opposed to text). anaconda-core (graphical installer) gets installed and has a dependency of firewalld in its spec file. Removing anaconda-core (and its dependency anaconda-tui) should be OK once the OS is installed. After removing anaconda-core I was able to remove firewalld with rpm -e. Haven't tested the undercloud install after this, but I suspect it should succeed past this error. Will try to confirm this workaround shortly.

--- Additional comment from Igal Katzir on 2017-02-12 04:50:08 EST ---

Thanks Andrew,

I have removed few packages :
anaconda-core, anaconda-tui, initial-setup-gui, anaconda-gui, and then I was able to remove the firewalld.

Then I have run again the installation script which finished successfully -

#############################################################################
Undercloud install complete.

I believe this Bug can be closed now, but maybe you should mention in the instillation manual this limitation about Server-Gui issue.
 
Igal

Comment 2 Gurenko Alex 2017-04-23 12:21:49 UTC
Verified with 2017-04.20.2 build

Comment 3 errata-xmlrpc 2017-05-17 20:05:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.