Bug 1429849 - Pull-through not working for registry.access.redhat.com images
Summary: Pull-through not working for registry.access.redhat.com images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.4.z
Assignee: Michal Minar
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-07 09:52 UTC by Vladislav Walek
Modified: 2020-07-16 09:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some registries (at least registry.access.redhat.com) don't allow for range requests on blobs or they reply with unexpected way. Consequence: Integrated registry failed to serve blobs directly (using pull-through) from such registries because it required a seek-able stream. Fix: Integrated registry now doesn't require the stream to be seek-able. Result: Integrated registry can now serve blobs directly from remote registries using pull-through even if they don't support range requests.
Clone Of:
Environment:
Last Closed: 2017-06-15 18:36:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1425 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.2 bug fix update 2017-06-15 22:35:53 UTC

Description Vladislav Walek 2017-03-07 09:52:37 UTC
Description of problem:

There is thread ongoing in openshift-sme mailing channel, but there is a case for it. The main question is, there is github for origin 1.5
https://github.com/openshift/origin/commit/1afd938a7eebe8cd9b5df1633df847e7e6e6492d

My question is, will that be included in 3.5 ?

Version-Release number of selected component (if applicable):
Openshift Container Platform 3.4.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Michal Fojtik 2017-03-07 09:59:34 UTC
(In reply to Vladislav Walek from comment #0)
> Description of problem:
> 
> There is thread ongoing in openshift-sme mailing channel, but there is a
> case for it. The main question is, there is github for origin 1.5
> https://github.com/openshift/origin/commit/
> 1afd938a7eebe8cd9b5df1633df847e7e6e6492d
> 
> My question is, will that be included in 3.5 ?
> 
> Version-Release number of selected component (if applicable):
> Openshift Container Platform 3.4.1
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

The commit was merged to 1.5 branch, so it should be included.

Comment 9 Michal Minar 2017-05-10 11:35:29 UTC
Merged

Comment 10 ge liu 2017-05-12 07:57:34 UTC
Verified on both 3.4 and 3.5 ocp env:

openshift v3.5.5.15
kubernetes v1.5.2+43a9be4
etcd 3.1.0

# oc import-image my-dotnet/dotnetcore-11-rhel7 --from=registry.access.redhat.com/dotnet/dotnetcore-11-rhel7 --confirm 
The import completed successfully.
#  docker login -u geliu -p 3DHRDjorKSrRl4ojJrdDjCd3t6nQ9PEySKBIghUkeS4 -e geliu@redhat.com 172.x.x.x:5000
Flag --email has been deprecated, will be removed in 1.13.
Login Succeeded

# docker -D pull 172.x.x.x:5000/lgproj1/dotnetcore-11-rhel7
Using default tag: latest
Trying to pull repository 172.x.x.x:5000/lgproj1/dotnetcore-11-rhel7 ... 
sha256:c8edcc7ad73d83f1fc49bba0efbd82de4c59b4ec0f57e214c1773b6cb09e48a8: Pulling from 172.30.95.56:5000/lgproj1/dotnetcore-11-rhel7
8642dd241e54: Already exists 
fdd633d880f7: Already exists 
9864a1e383b2: Pull complete 
Digest: sha256:c8edcc7ad73d83f1fc49bba0efbd82de4c59b4ec0f57e214c1773b6cb09e48a8
Status: Downloaded newer image for 172.x.x.x:5000/lgproj1/dotnetcore-11-rhel7:latest

openshift v3.4.1.23
kubernetes v1.4.0+776c994
etcd 3.1.0-rc.0

# oc import-image my-dotnet/dotnetcore-11-rhel7 --from=registry.access.redhat.com/dotnet/dotnetcore-11-rhel7 --confirm 
The import completed successfully.

# docker login -u geliu -p 9hKYwqeAkZt9qSdAoCBz2z7qqgF6qVh1Fg3yb0NRggQ -e geliu@redhat.com 172.30.x.x:5000
Flag --email has been deprecated, will be removed in 1.13.

# docker -D pull 172.x.x.x:5000/lgproj/dotnetcore-11-rhel7
Using default tag: latest
Trying to pull repository 172.30.x.x:5000/lgproj/dotnetcore-11-rhel7 ... 
sha256:c8edcc7ad73d83f1fc49bba0efbd82de4c59b4ec0f57e214c1773b6cb09e48a8: Pulling from 172.30.1.187:5000/lgproj/dotnetcore-11-rhel7
8642dd241e54: Already exists 
fdd633d880f7: Already exists 
9864a1e383b2: Pull complete 
Digest: sha256:c8edcc7ad73d83f1fc49bba0efbd82de4c59b4ec0f57e214c1773b6cb09e48a8
Status: Downloaded newer image for 172.30.x.x:5000/lgproj/dotnetcore-11-rhel7:latest

Comment 12 errata-xmlrpc 2017-06-15 18:36:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1425


Note You need to log in before you can comment on or make changes to this bug.