Bug 143000 - Installer provides confusing message
Summary: Installer provides confusing message
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-15 17:19 UTC by Sean E. Millichamp
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 20:13:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sean E. Millichamp 2004-12-15 17:19:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I was helping a coworker try to upgrade his FC2 installation to FC3. 
After selecting to perform an "Upgrade" installation anaconda would
pop up an error message saying:

"Error enabling swap device /dev/hdd3:  This most likely means this
swap partition has not been initialized.  Press OK to reboot your system."

Now, this confused both of us because he didn't have an /dev/hdd on
his system.  We ended up checking all the IDE jumper settings, the
BIOS config, etc. - basically I was stuck and assumed it was a
kernel/anaconda bug.

Of course, what anaconda is really doing is finding your /etc/fstab
from the old installation and assuming it is correct.  But the error
message never says anything about where it obtained this /dev/hdd3
value from.  I have been using Red Hat products since RHL 4.1 and I
almost didn't think to check for that.  A less experienced user might
never have resolved the problem.  The user of this station moved his
drive from one IDE position to another and it had all the appearances
of working in Fedora Core 2 without realizing his swap was no longer
working.

Version-Release number of selected component (if applicable):
anaconda-10.1.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Reference a bad swap partition in /etc/fstab
2. Run anaconda to perform an upgrade
3. Watch it error out and quit
    

Actual Results:  Anaconda displays:

Error enabling swap device /dev/hdd3:  This most likely means this
swap partition has not been initialized.  Press OK to reboot your system.


Expected Results:  Anaconda should explain where it is obtaining the
swap information from so the when average user relocates his hard
drive from one position to another he can at least understand the
source of the message.

While swap was never starting on FC2 most users would not notice this
and there was no obvious error message regarding the failure of swap
to initialize.  Anaconda should either be as forgiving as the regular
boot process or provide enough information in the error message that a
more "normal" Linux user would have a chance of solving the problem
themselves.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.