Bug 1430314 - The ipa-managed-entries command failed, exception: AttributeError: ldap2
Summary: The ipa-managed-entries command failed, exception: AttributeError: ldap2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Sudhir Menon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-08 11:06 UTC by Sudhir Menon
Modified: 2017-08-01 09:44 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Sudhir Menon 2017-03-08 11:06:19 UTC
Description of problem: The ipa-managed-entries command failed, exception: AttributeError: ldap2


Version-Release number of selected component (if applicable):

ipa-server-common-4.4.90-201703072305.el7.noarch
ipa-server-dns-4.4.90-201703072305.el7.noarch
ipa-server-4.4.90-201703072305.el7.x86_64

How reproducible: Always

Steps to Reproduce:
1. Install ipa-server
2. Try running the below commands

ipa-managed-entries enable/status/disable

Actual results:
    [root@intel ~]# ipa-managed-entries enable -d
    ipa         : DEBUG    importing all plugin modules in ipaclient.remote_plugins.schema$e2bd3f45...
    ipa         : DEBUG    importing plugin module ipaclient.remote_plugins.schema$e2bd3f45.plugins
    ipa         : DEBUG    importing all plugin modules in ipaclient.plugins...
    ipa         : DEBUG    importing plugin module ipaclient.plugins.automember
    ipa         : DEBUG    importing plugin module ipaclient.plugins.automount
    ipa         : DEBUG    importing plugin module ipaclient.plugins.ca
    ipa         : DEBUG    importing plugin module ipaclient.plugins.cert
    ipa         : DEBUG    importing plugin module ipaclient.plugins.certprofile
    ipa         : DEBUG    importing plugin module ipaclient.plugins.csrgen
    ipa         : DEBUG    importing plugin module ipaclient.plugins.dns
    ipa         : DEBUG    importing plugin module ipaclient.plugins.hbacrule
    ipa         : DEBUG    importing plugin module ipaclient.plugins.hbactest
    ipa         : DEBUG    importing plugin module ipaclient.plugins.host
    ipa         : DEBUG    importing plugin module ipaclient.plugins.idrange
    ipa         : DEBUG    importing plugin module ipaclient.plugins.internal
    ipa         : DEBUG    importing plugin module ipaclient.plugins.location
    ipa         : DEBUG    importing plugin module ipaclient.plugins.migration
    ipa         : DEBUG    importing plugin module ipaclient.plugins.misc
    ipa         : DEBUG    importing plugin module ipaclient.plugins.otptoken
    ipa         : DEBUG    importing plugin module ipaclient.plugins.otptoken_yubikey
    ipa         : DEBUG    importing plugin module ipaclient.plugins.passwd
    ipa         : DEBUG    importing plugin module ipaclient.plugins.permission
    ipa         : DEBUG    importing plugin module ipaclient.plugins.rpcclient
    ipa         : DEBUG    importing plugin module ipaclient.plugins.server
    ipa         : DEBUG    importing plugin module ipaclient.plugins.service
    ipa         : DEBUG    importing plugin module ipaclient.plugins.sudorule
    ipa         : DEBUG    importing plugin module ipaclient.plugins.topology
    ipa         : DEBUG    importing plugin module ipaclient.plugins.trust
    ipa         : DEBUG    importing plugin module ipaclient.plugins.user
    ipa         : DEBUG    importing plugin module ipaclient.plugins.vault
    ipa         : DEBUG      File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 892, in run_script
        return_value = main_function()
     
      File "/usr/sbin/ipa-managed-entries", line 78, in main
        api.Backend.ldap2.connect(bind_pw=options.dirman_password)
     
      File "/usr/lib/python2.7/site-packages/ipalib/plugable.py", line 335, in __getattr__
        raise AttributeError(key)
     
    ipa         : DEBUG    The ipa-managed-entries command failed, exception: AttributeError: ldap2
    Unexpected error
    AttributeError: ldap2


Expected results: Should show status, enable or disable ipa-managed-entries

Additional info:

Comment 2 Martin Babinsky 2017-03-08 11:26:38 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6735

Comment 6 Sudhir Menon 2017-05-25 11:55:09 UTC
Unexpected error is no more seen. Tested on RHEL7.4

[root@master ~]# rpm -q ipa-server krb5-server selinux-policy sssd pki-server pki-ca 389-ds-base
ipa-server-4.5.0-13.el7.x86_64
krb5-server-1.15.1-8.el7.x86_64
selinux-policy-3.13.1-152.el7.noarch
sssd-1.15.2-35.el7.x86_64
pki-server-10.4.1-4.el7.noarch
pki-ca-10.4.1-4.el7.noarch
389-ds-base-1.3.6.1-14.el7.x86_64


ipa         : DEBUG    importing plugin module ipaserver.plugins.xmlserver
ipa.ipaserver.plugins.ldap2.ldap2: DEBUG    Created connection context.ldap2_40652496
ipa         : DEBUG      File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 906, in run_script
return_value = main_function()
File "/usr/sbin/ipa-managed-entries", line 114, in main
sys.exit("\nYou must specify a managed entry definition")
ipa         : DEBUG    The ipa-managed-entries command failed, exception: SystemExit: 
You must specify a managed entry definition

Comment 7 errata-xmlrpc 2017-08-01 09:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.