Bug 143037 - Error while processing get: Invalid argument --> SIGSEGV received
Summary: Error while processing get: Invalid argument --> SIGSEGV received
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: ccs   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-15 21:39 UTC by Adam "mantis" Manthei
Modified: 2009-04-16 20:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 18:24:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
in-memory cluster.conf (1.67 KB, text/plain)
2004-12-15 21:39 UTC, Adam "mantis" Manthei
no flags Details

Description Adam "mantis" Manthei 2004-12-15 21:39:54 UTC
Created attachment 108655 [details]
in-memory cluster.conf

Comment 1 Adam "mantis" Manthei 2004-12-15 21:39:54 UTC
Description of problem:
ccsd segfaulted while running ccs_test.  from the logs...

Dec 15 15:18:22 trin-01 ccsd[8482]: Error: unable to evaluate xpath query
"/cluster/" 
Dec 15 15:18:22 trin-01 ccsd[8482]: Error while processing get: Invalid argument 
Dec 15 15:18:33 trin-01 ccsd[8482]: Stopping ccsd, SIGSEGV received. 


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.906_EL
cman-kernel-2.6.9-3.3
ccs-0.9-0
cman-1.0-0.pre5.0
fence-1.3-1

How reproducible:
haven't tried... I've only seen it the one time so far

Steps to Reproduce:
[root@trin-01 fenced]# ccs_test connect
Connect successful.
 Connection descriptor = 3

[root@trin-01 fenced]# ccs_test get 3 /cluster
Get successful.
 Value = <
        >
[root@trin-01 fenced]# ccs_test get 3 /cluster/
ccs_get failed: Invalid argument

[root@trin-01 fenced]# ccs_test get 3 /cluster/fence_daemon
ccs_get failed: Invalid exchange

[root@trin-01 fenced]# ccs_test get 3 /cluster/fence_daemon/

<<-- here is where I noticed that ccsd SEGV'ed in the logs -->>
  
Actual results:
segfault

Expected results:
no segfault

Additional info:
I had the fence_domain running at the time and had been trying to update the
cluster.conf a couple of times.  I often had to retry updating ccs because I
kept forgetting to update the version number of the config file.  I don't know
if that had anything to do with this though.

Comment 2 Jonathan Earl Brassow 2004-12-17 18:24:24 UTC
I am unable to reproduce this bug.  (I started working on it after the
update fixes, which may have played a partial roll.)  Generally, an
'invalid exchange' error is due to not being able to receive or send a
(complete) package.  I've looked at all the places where this error
code is set and found nothing.  Perhaps it has to do with the previous
EINVAL error, but I can't find anything wrong with this either...

This did uncover another bug, however.  One which only occurred if the
working path had been set.  This has been fixed.




Note You need to log in before you can comment on or make changes to this bug.