Bug 143068 - .discinfo file should have something that tells it is a Update CD
.discinfo file should have something that tells it is a Update CD
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: comps (Show other bugs)
5.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dennis Gregorovic
Jay Turner
IT_48121
Distribution
: FutureFeature, Reopened
Depends On:
Blocks: 184191 459403
  Show dependency treegraph
 
Reported: 2004-12-16 05:32 EST by Issue Tracker
Modified: 2015-01-07 19:09 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:18:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2004-12-16 05:32:07 EST
Escalated to Bugzilla from IssueTracker
Comment 1 Susan Denham 2004-12-16 05:34:28 EST
 Request from the Dell Server Asistant CD team, whose product helps install OSs.

discinfo file on RH CDs should have something in it that tells it is an update
CD. This will be helpful for people (DSA) who wants to differenciate Update CDs
with original Gold CDs.

Current contents of .discinfo:

=========================
1065565780.808209
Red Hat Enterprise Linux 3
i386
1
RedHat/base
RedHat/RPMS
RedHat/pixmaps
==========================

Any change to this that indicates which Update CD it is would be great. Simply
adding "Update X" to the end of the "Red Hat Enterprise Linux 3" line would be
ok. Another line with the update version would be ok also. We really don't mind
so much exactly how it is added.

The important thing is that the information needs to stay the same if the media
is ever slipstreamed (ie. the old gold vs "real" gold2 issue). I don't know what
the number in the first line is supposed to represent and so do not trust it to
stay the same for slipstream CDs.
Comment 4 David Lawrence 2006-03-03 13:46:21 EST
The bug status ASSIGN_TO_PM has been deprecated. In the future please use
ASSIGNED and either add the PM to the Cc list or re-assign report to them.
Comment 5 Issue Tracker 2006-03-14 15:22:11 EST
From User-Agent: XML-RPC

------- Additional Comments From sdenham@redhat.com  2004-12-16 05:34
-------
 Request from the Dell Server Asistant CD team, whose product helps install
OSs.

discinfo file on RH CDs should have something in it that tells it is an
update
CD. This will be helpful for people (DSA) who wants to differenciate Update
CDs
with original Gold CDs.

Current contents of .discinfo:

=========================
1065565780.808209
Red Hat Enterprise Linux 3
i386
1
RedHat/base
RedHat/RPMS
RedHat/pixmaps
==========================

Any change to this that indicates which Update CD it is would be great.
Simply
adding "Update X" to the end of the "Red Hat Enterprise Linux 3" line
would be
ok. Another line with the update version would be ok also. We really don't
mind
so much exactly how it is added.

The important thing is that the information needs to stay the same if the
media
is ever slipstreamed (ie. the old gold vs "real" gold2 issue). I don't
know what
the number in the first line is supposed to represent and so do not trust
it to
stay the same for slipstream CDs.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143068

Bugzilla Status changed from NEW to ASSIGN_TO_PM
Bugzilla Summary changed from "RHEL3 U5: .discinfo fileshould have
something thattells it is a Update CD" to "RHEL3 U5: .discinfo fileshould
have something thattells it is a Update CD"

This event sent from IssueTracker by ltroan 
 issue 48121
Comment 6 Issue Tracker 2006-03-14 15:22:27 EST
From User-Agent: XML-RPC

Matt:  The only potential flaw here is that we try to only change disc1 in
these updates.  So you would still end up in the case where disc1 was
marked as an update but the remainder of the discs were marked as GA.   I
don't think that would really solve your problem....

Status set to: Waiting on Client (Long Term)

This event sent from IssueTracker by ltroan 
 issue 48121
Comment 23 Tim Powers 2006-07-24 13:23:43 EDT
I'm putting this in "modified" because we can't extend .discinfo itself. What we can do is provide the full 
version number when there is an update instead of just putting "Red Hat Enterprise Linux 5". When there is 
an update release it will be something like "Red Hat Enterprise Linux 5.1" etc.
Comment 24 Jay Turner 2006-09-28 06:57:57 EDT
Fix confirmed with the RHEL5-Server-20060921.0 trees.  We have the following in
.discinfo:

---
1158847960.715069
Red Hat Enterprise Linux Server 4.91
i386
1
Server/base
Server/RPMS
Server/pixmaps
---

A similiar format exists on the Client media as well.
Comment 25 Amit Bhutani 2006-10-02 20:36:20 EDT
This should work for us. Thanks for implementing. This request can now be 
closed.
Comment 27 Charles Rose 2008-05-28 06:13:52 EDT
With RHEL 5.2, we still do not see the update information referred to in Comment #24

[charles@ost x86_64]$ cat
/var/ftp/pub/iso/RHEL5.2-Server-20080430.0-x86_64-disc1-ftp.iso/.discinfo
1209608466.515430
Red Hat Enterprise Linux Server 5
x86_64
1
S/base
S/RPMS
S/pixmaps
Comment 32 Dennis Gregorovic 2008-08-07 16:06:47 EDT
Change checked into distill.  Should show up in the next set of trees.
Comment 38 errata-xmlrpc 2009-01-20 16:18:46 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0133.html

Note You need to log in before you can comment on or make changes to this bug.