Bug 1430682 - Do not allow user to provide colon separated values for a auth.ssl-allow key
Summary: Do not allow user to provide colon separated values for a auth.ssl-allow key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 1417151 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-03-09 09:54 UTC by RamaKasturi
Modified: 2017-09-21 04:49 UTC (History)
7 users (show)

Fixed In Version: gdeploy-2.0.2-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description RamaKasturi 2017-03-09 09:54:40 UTC
Description of problem:
In a environment where customers are working with IPV6 address, colon separated values for auth-ssl.allow does not work as IPV6 address is colon separated. Remove the support for separation of values using colon and use only semicolon.

Version-Release number of selected component (if applicable):
gdeploy-2.0.1-11.el7rhgs.noarch

How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:
Remove the support for separation of values using colon as IPV6 address is also colon separated.

Additional info:

Comment 5 Sachidananda Urs 2017-03-23 11:42:16 UTC
Commit: https://github.com/gluster/gdeploy/commit/d720fe5f78 fixes the issue.

Comment 6 RamaKasturi 2017-05-22 10:45:30 UTC
Verified and works fine with gdeploy-2.0.2-10.el7rhgs.noarch.

With this fix, values in auth-ssl.allow  are only separated using ',' if the values are specified using ';'

Comment 8 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.