Bug 143075 - Mouse unusable when evolution is in sessions list
Mouse unusable when evolution is in sessions list
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 07:12 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 03:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-12-16 07:12:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
This is a weird one.
Since installing vmware..

my mouse has not acted properly when first logging in to X.

When I click on icons and windows, I either get no response, or the
click is made somewhere else. For example, I right-click on the
desktop in the center, the menu appears to the side.

Ctrl+Alt+F1, Ctrl+Alt+F7 seems to help, as does right,left-clicking on
parts of the screen, as if I'm teaching the mouse where it is.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    xxx

Additional info:
Comment 1 Need Real Name 2004-12-21 09:29:20 EST
I can reproduce this on two machines.

If evolution is added as a startup app, using gnome's "sessions", the
mouse does not work at all properly when I log in to X.
Comment 2 Mike A. Harris 2005-01-31 22:21:37 EST
This sounds like evolution is grabbing the mouse, and not letting
go of it.  I don't know if that's the case or not, but I can't think
of any other logical explanation for why the above symptoms would
be seen.

Oddly, nobody else has reported this problem as far as I can see
either.

Reassigning to evolution component.
Comment 3 Mike A. Harris 2005-01-31 22:22:43 EST
I recommend getting an strace and ltrace of evolution running
when this problem occurs, and perhaps running it in a gdb session
to debug the issue.
Comment 4 Mike A. Harris 2005-01-31 22:24:46 EST
"Since installing vmware.."

I missed that in the original comment.  If this only happens
when using VMware (which is unsupported), you might also want
to report this to VMware Inc. and to X.Org bugzilla located
at http://bugs.freedesktop.org in the "xorg" component, in case
there is a problem with vmware's driver.
Comment 5 Dave Malcolm 2005-02-01 22:34:58 EST
What state is Evolution in when it starts up?  Does the main window
appear?  Any other dialogs?  Which component appears?  The mail
component or another?

Is this when running on a simulated computer inside VMware, or running
as the real computer?
Comment 6 Need Real Name 2005-02-02 02:57:38 EST
The host machine is Linux, at the point that I get the problem, I am
not running any virtual machines - but the vmware service has started
during boot.

X starts as usual - evolution is set to start with X.
evolution starts as usual.

The problem is that the mouse requires a lot of work to get it to
start behaving.
Comment 7 Mike A. Harris 2005-02-07 20:57:07 EST
Ok, to clarify, you are booting Linux outside of VMware, and running
evolution also outside of vmware, only the vmware system service
(and thus also the vmware unsupported kernel modules) are running.

If you disable the vmware service at boot, and ensure the vmware
kernel modules never load at all, does the problem go away?
Comment 8 Need Real Name 2005-02-08 15:35:46 EST
Yes.

I will try to test this tomorrow, but iirc it is only a problem when
evolution is started automatically from Sessions.
Comment 9 Need Real Name 2005-02-15 03:53:12 EST
I can no longer reproduce this. Will reopen if it happens again.

Note You need to log in before you can comment on or make changes to this bug.