Bug 1430785 - Incorrect units for time measurement
Summary: Incorrect units for time measurement
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ioping
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Fabio Alessandro Locati
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/koct9i/ioping/issu...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-09 15:25 UTC by Bryan Harris
Modified: 2018-10-02 16:44 UTC (History)
4 users (show)

Fixed In Version: ioping-1.1-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-02 16:44:09 UTC


Attachments (Terms of Use)

Description Bryan Harris 2017-03-09 15:25:23 UTC
Description of problem:
In both old and new version of ioping, the man page says the times given should be in microseconds.  However, in the new ioping the times are being given in nanoseconds (off by an order of a thousand).  However, the problem is only when using the "-q" command line switch.  The normal usage works according to the man page.

Version-Release number of selected component (if applicable):
1.0-1.el6

How reproducible:
100%

Steps to Reproduce:
1. Install latest EPEL ioping
2. Compare below commands:
3. ioping / -c 5 -p 5
4. ioping -q / -c 5 -p 5

Actual results:
Times are in nanoseconds

Expected results:
Times should be in microseconds

Additional info:
This happened with the update to the new ioping version last month.

Comment 1 Bryan Harris 2017-03-09 15:38:26 UTC
I have a slight correction to make.

Actual results:
Times using -q flag are in nanoseconds

Expected results:
Times using -q flag should be in microseconds

Comment 2 Robin Lee 2018-09-04 09:57:08 UTC
Add upstream issue URL

Comment 3 Fedora Update System 2018-09-16 16:13:47 UTC
ioping-1.1-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5b08a34952

Comment 4 Fedora Update System 2018-09-17 03:41:07 UTC
ioping-1.1-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5b08a34952

Comment 5 Fedora Update System 2018-10-02 16:44:09 UTC
ioping-1.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.