Bug 1430815 - I18N component breaks nodes actions toolbar
Summary: I18N component breaks nodes actions toolbar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Florian Fuchs
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-09 16:09 UTC by Ola Pavlenko
Modified: 2017-05-17 20:06 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-ui-3.1.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:06:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 444165 None None None 2017-03-13 10:31:48 UTC
Launchpad 1671100 None None None 2017-03-09 16:09:57 UTC

Description Ola Pavlenko 2017-03-09 16:09:57 UTC
Description of problem:
The <FormattedMessage> component used for I18N adds an additional span tag to some of the buttons in the nodes actions toolbar. If this button is clicked, the event target is the span element, not the button element. The button element however has a "name" attribute which is needed to determine what to do after the click. Since the button is no longer the target of the click event, this attribute isn't recognized and nothing happens.

This could be fixed by checking the name attribute of the parent element of the event target.

As a workaround, users can use shift+tab after selecting a node to bring back the focus to the button and trigger the introspection by pressing enter.

This problem might occur in other places as well.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Julie Pichon 2017-03-13 10:31:48 UTC
Master patch + backport to Ocata/11 merged upstream.

Comment 3 Jon Schlueter 2017-03-15 12:56:40 UTC
Patch Merged upstream not yet into a build downstream

Comment 5 Ola Pavlenko 2017-03-16 12:56:37 UTC
Verified : openstack-tripleo-ui-3.1.0-3.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:06:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.