Bug 1430887 - Fix handling underscore in object name in file set_attrs
Summary: Fix handling underscore in object name in file set_attrs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Orit Wasserman
QA Contact: shilpa
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-09 19:08 UTC by Orit Wasserman
Modified: 2017-07-30 15:48 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-10.2.7-11.el7cp Ubuntu: ceph_10.2.7-12redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:30:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 18727 None None None 2017-03-09 19:08:12 UTC

Description Orit Wasserman 2017-03-09 19:08:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Matt Benjamin (redhat) 2017-04-04 16:55:56 UTC
@orit, is this fixed upstream?  can it be fixed for 2.3?

Comment 4 Orit Wasserman 2017-04-05 08:15:37 UTC
(In reply to Matt Benjamin (redhat) from comment #3)
> @orit, is this fixed upstream?  can it be fixed for 2.3?

This is fixed upstream in master, it is being backported to Jewel (it will be part of 10.2.8)

It can be fixed for 2.3

Comment 6 Orit Wasserman 2017-04-21 06:35:23 UTC
fix cherry-picked to ceph-2-rhel-patches

Comment 10 shilpa 2017-05-19 11:39:04 UTC
Verified on ceph-10.2.7-13.el7cp

Comment 12 errata-xmlrpc 2017-06-19 13:30:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.