Bug 1430908 - Request to merge Dell 3xxxx hwtable listings
Summary: Request to merge Dell 3xxxx hwtable listings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
URL:
Whiteboard:
: 1436255 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-09 20:44 UTC by John Pittman
Modified: 2017-08-01 16:34 UTC (History)
8 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-108.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 16:34:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch editing multipath.conf.defaults and hwtable.c (4.60 KB, patch)
2017-03-09 20:44 UTC, John Pittman
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1961 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2017-08-01 17:56:09 UTC

Description John Pittman 2017-03-09 20:44:31 UTC
Created attachment 1261696 [details]
patch editing multipath.conf.defaults and hwtable.c

Description of problem:

There are 6 different listings for the Dell 3xxxxx family in the hardware table, and they all have the same settings.  These should be combined using regex in .product line.  This will provide ease of use/viewing in multipath.conf.defaults, multipath.conf,  hwtable.c, and the 'multipath -t' command.

Version-Release number of selected component (if applicable):

device-mapper-multipath-0.4.9-103.el7

How reproducible:

Run 'multipath -t' and observe Dell 3xxxxx hardware table defaults.

Actual results:

6 separate listings

Expected results:

1 listing

Comment 2 Ben Marzinski 2017-03-10 20:13:44 UTC
I don't see a problem with this. However, upstream has already combined them (and some additional devices) into three configs (still identical) based on devices that share the same firmware. I'll ask upstream if anyone objects to combining them further, and I'll pull whatever the upstream result is back into RHEL.

Comment 5 Ben Marzinski 2017-04-25 21:12:46 UTC
Nobody upstream objected to combining them, so I'm fine it. I've also updated the config to use the upstream no_path_retry value (30 checks instead of 15), and changed the product regex to allow the MD38xxx devices as well.

Comment 6 Ben Marzinski 2017-04-25 21:15:03 UTC
*** Bug 1436255 has been marked as a duplicate of this bug. ***

Comment 8 Lin Li 2017-05-22 10:45:46 UTC
Verified on device-mapper-multipath-0.4.9-111.el7
[root@storageqe-84 ~]# rpm -qa | grep multipath
device-mapper-multipath-debuginfo-0.4.9-111.el7.x86_64
device-mapper-multipath-libs-0.4.9-111.el7.x86_64
device-mapper-multipath-0.4.9-111.el7.x86_64
device-mapper-multipath-sysvinit-0.4.9-111.el7.x86_64
device-mapper-multipath-devel-0.4.9-111.el7.x86_64

[root@storageqe-84 ~]# multipath -t | grep -C 11 DELL
	device {
		vendor "DELL"
		product "^MD3"     ------------------------->changed the product regex to allow the MD38xxx devices
		product_blacklist "Universal Xport"
		path_grouping_policy "group_by_prio"
		path_checker "rdac"
		features "2 pg_init_retries 50"
		hardware_handler "1 rdac"
		prio "rdac"
		failback immediate
		rr_weight "uniform"
		no_path_retry 30    ---------------->30 checks instead of 15
	}

Comment 9 errata-xmlrpc 2017-08-01 16:34:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1961


Note You need to log in before you can comment on or make changes to this bug.