Bug 1430928 - Cannot double click in Nautilus to open docx file with LibreOffice-writer after gnome-autoar upgrade.
Cannot double click in Nautilus to open docx file with LibreOffice-writer aft...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-autoar (Show other bugs)
25
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
: 1431404 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-09 16:48 EST by Vincent P.
Modified: 2017-03-27 12:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-autoar-0.2.2-1.fc25 gnome-autoar-0.2.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-22 15:22:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent P. 2017-03-09 16:48:09 EST
Description of problem:
After an update of gnome-autoar .docx files cannot be opened again with a double click in Nautilus.

Version-Release number of selected component (if applicable):
gnome-autoar.x86_64 0.2.1-1.fc25

How reproducible:


Steps to Reproduce:
1. Update to gnome-autoar.x86_64 0.2.1-1.fc25
2. Open Nautilus
3. Double click a .docx file to open (bij default in LibreOffice-writer)

Actual results:
.docx file gets extracted to a new folder

Expected results:
.docx file opens in LibreOffice-writer

Additional info:
- Context menu shows as the default action that will extract the file.
- Setting the default application via properties doesn't make a difference (LibreOffice-writer was already the default application)
- Workaround is to downgrade to gnome-autoar.x86_64 0.1.1-1.fc25
Comment 1 Kalev Lember 2017-03-09 16:52:25 EST
Adding Carlos to CC who worked on the MIME type changes upstream.
Comment 2 Vincent P. 2017-03-09 16:55:33 EST
Found this issue on system 'A', then updated system 'B' to find out it got the same problem after the upgrade.
Comment 3 Carlos Soriano 2017-03-10 11:21:06 EST
upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=779795
Comment 4 Joel C Ewing 2017-03-10 17:35:37 EST
I suspect this is also related to the most unwelcome change that double-clicking on zip and tgz files has also changed to default to "extract here" instead of the prior default of archive mounter.  Extremely annoying when one has many compressed files which are only rarely viewed and which you only want to retain long-term in a compressed state.

Natuilus now seems to assume that anything that could conceivably be expanded/decompressed ought to have that as its default action, with no way to override that choice of default.

From the users standpoint, the process for setting or overriding whether extraction should be invoked for a file type by default should be no different than whether some other application should be invoked by default.  At this point it appears that file extraction is "more equal" (in the "Animal Farm" sense) than any other application.
Comment 5 Kalev Lember 2017-03-14 06:04:32 EDT
*** Bug 1431404 has been marked as a duplicate of this bug. ***
Comment 6 Joel C Ewing 2017-03-14 10:15:54 EDT
For followers of this bug who haven't recently checked out the reference in comment 3, I was wrong, there IS a way to override this default behavior, either until the issue with .docx and simlar files that shouldn't be extracted is resolved, or if extraction by default is a behavior you just don't want for any compressed file format:

With Files/Nautilus open, right click on Files on the top bar of the desktop, select Preferences, select Behavior tab, and under "Compressed Files" turn off the option "Extract the files on open".  That allows the default application for the file type to be invoked.  From a right-click menu, the action of "Extract Here" may still be explicitly selected for a file that is in a compressed format, it just won't be a forced default action.

This new option is described somewhere, but is hard to discover if you don't already know it exists.
Comment 7 Vincent P. 2017-03-19 15:35:07 EDT
(In reply to Joel C Ewing from comment #6)

> With Files/Nautilus open, right click on Files on the top bar of the
> desktop, select Preferences, select Behavior tab, and under "Compressed
> Files" turn off the option "Extract the files on open".  That allows the
> default application for the file type to be invoked.  From a right-click
> menu, the action of "Extract Here" may still be explicitly selected for a
> file that is in a compressed format, it just won't be a forced default
> action.
> 

This worked for me. Though I didn't expect this behaviour to change on .docx and related files on an update. This is still an issue?
Comment 8 Fedora Update System 2017-03-21 10:13:48 EDT
gnome-autoar-0.2.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-072b0ab1b5
Comment 9 Fedora Update System 2017-03-21 10:14:02 EDT
gnome-autoar-0.2.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e6e9dd4432
Comment 10 Fedora Update System 2017-03-21 20:53:18 EDT
gnome-autoar-0.2.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-072b0ab1b5
Comment 11 ingli 2017-03-22 09:35:07 EDT
(In reply to Joel C Ewing from comment #6)
:
> 
> With Files/Nautilus open, right click on Files on the top bar of the
> desktop, select Preferences, select Behavior tab, and under "Compressed
> Files" turn off the option "Extract the files on open".  That allows the
> default application for the file type to be invoked.  From a right-click
> menu, the action of "Extract Here" may still be explicitly selected for a
> file that is in a compressed format, it just won't be a forced default
> action.

This worked for me.
Comment 12 Fedora Update System 2017-03-22 11:27:04 EDT
gnome-autoar-0.2.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e6e9dd4432
Comment 13 Fedora Update System 2017-03-22 15:22:12 EDT
gnome-autoar-0.2.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Nestor Waldyd 2017-03-22 17:02:37 EDT
Hello,

With gnome-autoar-0.2.2-1.fc25 installed, the problem still persists.
Comment 15 Fedora Update System 2017-03-27 12:28:07 EDT
gnome-autoar-0.2.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.