Bug 1431115 - ovs 2.5 to 2.6 tripleo upgrade&update broken because the special case handling must be removed
Summary: ovs 2.5 to 2.6 tripleo upgrade&update broken because the special case handlin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 10.0 (Newton)
Assignee: Marios Andreou
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On: 1431108
Blocks: 1408224
TreeView+ depends on / blocked
 
Reported: 2017-03-10 12:18 UTC by Marios Andreou
Modified: 2017-06-28 14:46 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.2.0-18.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1431108
Environment:
Last Closed: 2017-06-28 14:46:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1669714 0 None None None 2017-03-10 12:18:31 UTC
OpenStack gerrit 441192 0 None None None 2017-03-10 12:20:44 UTC
OpenStack gerrit 458737 0 None None None 2017-04-21 06:56:39 UTC
Red Hat Product Errata RHBA-2017:1585 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-06-28 18:42:51 UTC

Description Marios Andreou 2017-03-10 12:18:31 UTC
+++ This bug was initially created as a clone of Bug #1431108 +++
(cloning for OSP10, from the original bug for OSP 11 ^^^^)
Description of problem:

As described in the upstream bug at https://bugs.launchpad.net/tripleo/+bug/1669714 wherever openvswitch 2.6 becomes available, any attempt to perform major upgrade or minor update on those nodes is subject to node connectivity problems and ultimately need reboot. We need to remove the special case handling that was previously required when we were going from 2.4 to 2.5.

Comment 1 Assaf Muller 2017-03-23 17:37:22 UTC
According to https://bugzilla.redhat.com/show_bug.cgi?id=1424945, the workaround is being added again. Closing this bug.

Comment 2 Marios Andreou 2017-03-28 09:00:33 UTC
Update: seems like we should *still* carry a special case upgrade for openvswitch and specifically ovs 2.5.0-14 - I've decided to use the same bug in an attempt to minimize the inevitable confusion here :(

Please see the discussion at https://bugzilla.redhat.com/show_bug.cgi?id=1424945#c11 for more information but essentially the workaround is the same as the one we previously had, with the addition of the '--notriggerun' flag for the package update.

I have just posted https://review.openstack.org/450607 Add special case upgrade from openvswitch 2.5.0-14 and matbu has this for the ansible steps at https://review.openstack.org/#/c/434346/

moving back to assigned. note that the related patches for removing the workaround had already landed in newton for 11 before this BZ was closed.

Adding the new reviews to the trackers (re-adding the workaround with extra flag) even though they aren't against newton (master in review still)

Comment 3 Marios Andreou 2017-04-21 06:56:40 UTC
Just cycled back here prompted by an email from Assaf. I was initially told to 'hold' on OSP10 and ovs 2.5 ++ as it wasn't clear what/when it would be available.

There are two parts, first we removed the old workaround since it was 'no longer necessary' with https://review.openstack.org/#/c/441192/ and then we re-added it with the --notriggerun flag. This second part we didn't do yet for Newton, so just posted https://review.openstack.org/#/c/458737/ for that and updated trackers, 


thanks

Comment 4 Steven Mercurio 2017-04-21 07:21:03 UTC
Please see also BZ#: 1416088.  We don't need the latest OVS ROM but we DEFINATELY need something newer.  There is some limitation in our AMD CPUs that wwas fixed in a later OVS (2.5.0-22) and all we had to do was pull it from the RHEV channel and make it available in the OSP10 channel and rudate this one RPM only in the images just prior to uploading them to glance.

Comment 5 Marios Andreou 2017-04-21 09:54:35 UTC
moving POST https://review.openstack.org/#/c/458737/ just merged to Newton.

Comment 12 errata-xmlrpc 2017-06-28 14:46:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1585


Note You need to log in before you can comment on or make changes to this bug.