Bug 1431171 (CVE-2016-8714) - CVE-2016-8714 R: Buffer overflow in the LoadEncoding functionality
Summary: CVE-2016-8714 R: Buffer overflow in the LoadEncoding functionality
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2016-8714
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1431174 1431173
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-10 14:17 UTC by Andrej Nemec
Modified: 2021-02-17 02:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:08:54 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-03-10 14:17:48 UTC
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.

External References:

http://www.talosintelligence.com/reports/TALOS-2016-0227/

Comment 1 Andrej Nemec 2017-03-10 14:18:37 UTC
Created R tracking bugs for this issue:

Affects: epel-all [bug 1431174]
Affects: fedora-all [bug 1431173]

Comment 2 Product Security DevOps Team 2019-06-08 03:08:54 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.