Bug 143122 - Needs update to graphviz-2.2
Needs update to graphviz-2.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 13:13 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-23 11:28:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to graphiz.spec for graphviz-2.2 (4.62 KB, patch)
2005-01-22 08:08 EST, John Ellson
no flags Details | Diff
Updated graphviz spec patch (5.59 KB, patch)
2005-01-22 18:29 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description John Ellson 2004-12-16 13:13:10 EST
Description of problem:
Needs update to graphviz-2.0  (Now under CPL)

Also, as one of the graphviz authors, how can I get plugged in to
at least automatically receive all bugzilla reports against graphviz?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2005-01-21 14:22:57 EST
Tempus fugit.     graphviz-2.2 is now available (and recommended).
Comment 2 John Ellson 2005-01-21 19:59:48 EST
Michael Schwendt asked (on fedora-devel) if any packages that depend
on graphviz are affected by an upgrade to 2.2.

As far as I can tell there are no such packages at this time in fedora
or fedora-extras, with the possible exception of "doxygen" which has
an optional dependency.   Doxygen works with the upgrade as I use it
myself.

"perl-Graphviz" is not currently included in extras, but is unlikely
to be affected since it uses the stdin/stdout interfaces to dot which
we keep very stable.

"webdot" is not currently included in extras, but thats mine and it
works with the upgrade to 2.2.

If other packages that depend on graphviz, I would like to know about
them so that I can test them before future releases.

There are very few code changes between 1.16 and 2.2.  The major
change is the switch to CPL.  I was under the impression that the old
AT&T license was unnacceptable to Redhat, so the change to CPL should
be a sufficient reason to upgrade.
Comment 3 Ville Skyttä 2005-01-22 05:12:10 EST
I grepped through the Extras CVS repository and found that these
packages have an explicit dependencies on graphviz: rpmDirectoryCheck,
libxml++, icu, and taglib.

AFAICS rpmDirectoryCheck is the only one of those that uses graphviz
for something else than in generating doxygen docs at build time. 
Assuming doxygen is not affected by the update, there's not much to test.

If you'd like to update the current Extras graphviz package to the
latest version, go ahead and submit a specfile patch here.  I can take
care of it too, but I'm afraid I cannot test it very thoroughly right
now.  Let me know what you think.
Comment 4 John Ellson 2005-01-22 08:07:25 EST
Thanks.

I to a quick look a rpmDirectoryCheck on an x86_64 FC4(-)
system, but it seems to have its own problems without graphviz.
It only uses dot as a command-line postprocessor, so it is very
likely unaffected by the upgrade to 2.2.

Patch to graphviz-spec follows.   I've tested it on x86_64 FC4
but the changes follow my own spec file which also works on RH7.3
and later.
Comment 5 John Ellson 2005-01-22 08:08:38 EST
Created attachment 110090 [details]
patch to graphiz.spec for graphviz-2.2
Comment 6 Ville Skyttä 2005-01-22 18:29:45 EST
Created attachment 110095 [details]
Updated graphviz spec patch

Here's an updated patch, see %changelog for changes.  Let me know what you
think; with your approval, I'll commit this to Extras CVS.

By the way, there's no comment format in specfiles for %macros.  Two %'s as in
%%foo means literal "%" followed by "foo", that can be used to emulate comments
to some extent.
Comment 7 John Ellson 2005-01-22 21:28:21 EST
Per our discussion, there is no need for any lib*tcl.so* symlinks
to be installed as the pkgIndex.tcl refers to the .so.x.x.x files
directly and these are tcl packages, not reusable libraries. I think
we concluded to explicitly exclude some that I'd missed?

No harm if they are left in, so its really up to you.

Otherwise you have my approval, and my thanks for your efforts.
Comment 8 Ville Skyttä 2005-01-23 11:28:21 EST
Committed, updated packages for FC1-FC3 should appear soonish.  Thanks.
Comment 9 Ville Skyttä 2005-01-23 13:14:19 EST
FC1 and FC2 builds are now available in fedora.us "pending", waiting for
verification.  http://fedoraproject.org/wiki/Extras/PendingRepository

Note You need to log in before you can comment on or make changes to this bug.