Bug 143126 - (IT_57523) autofs reads all auto.master maps
autofs reads all auto.master maps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 13:47 EST by David Lehman
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-178
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 18:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2004-12-16 13:47:11 EST
Description of problem:
The automounter init scripts are supposed to honour settings in
/etc/nsswitch.conf for determining the master map. So, if nsswitch.conf contains
'files nis', then it should check in /etc/auto.master for any maps & if none are
found, then check in NIS for any maps.

What the current scripts do, however, is to take the UNION of all the maps in
/etc/auto.master & NIS. So, when trying to use /etc/auto.master to override
what's in NIS, you end up with multiple definitions for the same mount point.

Version-Release number of selected component (if applicable):
autofs-4.1.3-12

How reproducible:
Always

Steps to Reproduce:
1. Set up nsswitch.conf to look in nis then files for automount maps
2. configure an auto.master in both NIS and /etc/auto.master
3. start autofs
  
Actual results:
the master map will contain all entries from both master maps

Expected results:
master map is whichever autofs found first (not both)

Additional info:
This has been fixed in the Fedora Core 3 version of autofs RPM. We'd like to get
this into the next RHEL3 errata.
Comment 1 Jeffrey Moyer 2004-12-16 13:50:14 EST
I am quite clear on how the current automounter operates with regards to this
issue.  However, last I tried to change the behaviour to match that of the Sun
automounter, I had users reporting regressions, since they had come to rely on
the current behaviour.  I will work to see if the +map syntax in auto.master
would be an acceptable alternative to those complaining of regressions.

-jeff
Comment 4 Dennis Gregorovic 2005-05-19 18:05:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-177.html

Note You need to log in before you can comment on or make changes to this bug.