Bug 14314 - gcolorsel crashes with "assertion failed"
Summary: gcolorsel crashes with "assertion failed"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-utils   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
: 16601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-20 15:59 UTC by Michael Redinger
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 09:34:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2000-07-20 15:59:54 UTC
The following 3 actions kill gcolorsel (error message on the command line
below the actions):

Edit -> Edit selected colors ... (RMB and same entry works too, same for
the other actions)
** WARNING **: document not well formed!
 
** WARNING **: Could not parse file
 
** ERROR **: file view-color-edit.c: line 267 (view_color_edit_new):
assertion f
ailed: (gui != NULL)
aborting...
Aborted




Edit -> Properties ...
** WARNING **: document not well formed!
 
** WARNING **: Could not parse file
 
** ERROR **: file view-color-generic.c: line 209
(view_color_generic_get_control
): assertion failed: (prop->gui
!= NULL)
aborting...
Aborted 




Edit -> Preferences ...
** WARNING **: document not well formed!
 
** WARNING **: Could not parse file
 
** ERROR **: file dialog-prefs.c: line 238 (dialog_prefs): assertion
failed: (gu
i != NULL)
aborting...
Aborted

Comment 1 Kjartan Maraas 2000-07-21 22:33:15 UTC
Confirmed 1) and 3). but with a slightly different error message:

Gtk-WARNING **: invalid cast from `GnomeMDI' to `ViewColorGeneric'

** ERROR **: file menus.c: line 685 (edit_cb): assertion failed:
(IS_VIEW_COLOR_GENERIC (view))

This is the latest snapshot from GNOME CVS

Kjartan Maraas


Comment 2 mchampig 2000-07-22 02:07:04 UTC
This dies in the same way on Alpha too.


Comment 3 Alan Cox 2000-08-18 18:01:59 UTC
I see the malformed document crash. Seems the glade file is corrupt


Comment 4 Havoc Pennington 2000-08-21 15:39:12 UTC
*** Bug 16601 has been marked as a duplicate of this bug. ***

Comment 5 Havoc Pennington 2000-08-21 15:44:05 UTC
The RPM simply didn't have the glade files in the file list.  Uploading 
new RPM now. Oh, and this is a MUST-FIX


Note You need to log in before you can comment on or make changes to this bug.