Bug 143148 - vgcreate claim max 65k PV which is wrong for LVM2
vgcreate claim max 65k PV which is wrong for LVM2
Status: CLOSED DUPLICATE of bug 129701
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 16:19 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 12:39:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2004-12-16 16:19:36 EST
As you see below, I created VG with PE size 8kB under RHEL4b2 (LVM2)
on an 120GB HDD. Then I created VG and then LV with 13107200 LE (PE)
units.

Under LVM1 number of PE (LE) has been limited to 65535 and this causes
a lot of headaches because LV size limit.

The man page for vgcreate should be fixed for LVM2 to describe this
change and maybe suggestion to convert LVM1 to LVM2 to remove this
limitation.



# pvdisplay
  --- Physical volume ---
  PV Name               /dev/hdh
  VG Name               TEST
  PV Size               111,79 GB / not usable 0
  Allocatable           yes
  PE Size (KByte)       8
  Total PE              14652392
  Free PE               1545192
  Allocated PE          13107200
  PV UUID               wd6WMz-d6ag-6UUB-J5yY-HrmF-Dw87-XYIN1u

# vgdisplay
  --- Volume group ---
  VG Name               TEST
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  2
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                1
  Open LV               0
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               111,79 GB
  PE Size               8,00 KB
  Total PE              14652392
  Alloc PE / Size       13107200 / 100,00 GB
  Free  PE / Size       1545192 / 11,79 GB
  VG UUID               kR7EWz-MdTy-EZxn-2JFq-Ppqq-ygK2-tg3S6V

# lvdisplay
  --- Logical volume ---
  LV Name                /dev/TEST/lvol0
  VG Name                TEST
  LV UUID                vKWK3r-RKUt-6BQc-pniK-tOhd-23X8-L2lLjl
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                100,00 GB
  Current LE             13107200
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:1
Comment 1 Alasdair Kergon 2004-12-21 10:22:18 EST

*** This bug has been marked as a duplicate of 129701 ***

Note You need to log in before you can comment on or make changes to this bug.