Bug 1431486 - dnf wants to check gpg key on builddep from src.rpm
dnf wants to check gpg key on builddep from src.rpm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-12 21:20 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2017-04-01 13:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-01 13:22:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2017-03-12 21:20:22 EDT
Description of problem:
$ sudo dnf builddep molequeue-0.8.0-1.20161222giteb397e.fc27.src.rpm 
Last metadata expiration check: 0:57:01 ago on Sun Mar 12 20:11:48 2017.
Error: public key not available, add '--nogpgcheck' option to ignore package sign
Dependencies resolved.
Nothing to do.
Complete!
$ echo $?
0

Version-Release number of selected component (if applicable):
dnf-1.1.10-5.fc25.noarch
dnf-2.0.0-2.fc26.noarch
(same behaviour)

How reproducible:
deterministic

Two errors:
1. checking the gpg key on the src.rpm package makes no sense. I'm not trusting that package for anything except to provide a list of packages which I'll be installing from a trusted source. And I do not want to add --nogpgcheck as a work-around, because that'd also impact the installation phase, I expressly do not want to install unsigned packages.

AFAIK, dnf is NOT parsing the spec file, it's just looking at the list of requirements that the rpm itself declares.

2. the return code is wrong. I opened a bug for that somewhere, so just making a  note.
Comment 2 Fedora Update System 2017-03-21 09:04:31 EDT
dnf-plugins-core-1.1.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f56311f5dd
Comment 3 Fedora Update System 2017-03-22 11:26:43 EDT
dnf-plugins-core-1.1.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f56311f5dd
Comment 4 Fedora Update System 2017-04-01 13:22:57 EDT
dnf-plugins-core-1.1.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.