Bug 143152 - show desktop applet is easily confused
Summary: show desktop applet is easily confused
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-16 21:32 UTC by Carl Worth
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-18 02:02:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl Worth 2004-12-16 21:32:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The "Show Desktop" button does do what it is advertised to do
in the most simple usage. Clicking it shows the desktop, (the
button remains "pressed"). And clicking it again returns all
the hidden programs to their normal view).

But, if a new window is mapped while the show desktop button is
pressed, then it resets itself while leaving all hidden windows
in a limbo state.


Version-Release number of selected component (if applicable):
Show Desktop Button 2.8.1

How reproducible:
Always

Steps to Reproduce:
1. Open any application window
2. Click the show desktop button
3. Double-click Home icon to bring up a new window
4. Click show desktop again

Actual Results:  The original application is hidden by step 2 as expected.
Step 3 "deselects" the show desktop button.
But the second click in step 4 also hides the second window.

Expected Results:  In step 3 the show desktop button should have
remained selected.

Or, alternately, this button could reset as it does, but if so,
then it should have return all hidden windows to their normal state.

Additional info:

Windows in limbo are really confusing in several parts of the interface.
The workspace switcher applet continues to show them, and they
don't have the fade-out appearance of a minmized window in the window
list applet.

In every sense they look like they should be visible, except that
they aren't.

Comment 1 Mark McLoughlin 2004-12-17 12:55:43 UTC
The button just toggles _NET_SHOWING_DESKTOP - moving to metacity

Comment 2 Havoc Pennington 2004-12-18 02:02:52 UTC
This is the intended behavior I think:
http://bugzilla.gnome.org/show_bug.cgi?id=92335

If it's wrong (entirely possible) should discuss it upstream after
reading the historical discussion.


Note You need to log in before you can comment on or make changes to this bug.