Bug 143156 - New version available 3.4.5
New version available 3.4.5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pvm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 210869
  Show dependency treegraph
 
Reported: 2004-12-16 17:11 EST by Jonathan Underwood
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: pvm-3.4.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 18:21:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2004-12-16 17:11:42 EST
Description of problem:
New version available; currently included version 3.4.4 is out of
date, version 3.4.5 has been available since 09/08/04

Version-Release number of selected component (if applicable):
3.4.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
New version available from:
http://www.netlib.org/pvm3/index.html
Comment 1 Jonathan Underwood 2004-12-16 17:36:32 EST
Also, shouldn't the header files be made into a separate package to
conform with other fedora/rpm packaging practice such that there is
following rpms: pvm (containing the libraries), pvmd (the daemon),
pvmd-gui and pvm-devel (the header files). The following spec file for
pvm looks like a very good model:

http://cvs.pld.org.pl/SPECS/pvm.spec?rev=1.45
Comment 2 Jonathan Underwood 2004-12-16 18:13:50 EST
Also, note the patches applied in the specfile in Comment #2, in
particular the patch to have pvm working over ssh rather than rsh -
surely this is a good idea from a security perspective. Patches
available here:

http://cvs.pld.org.pl/SOURCES/

Comment 3 Wei-Lun Chao 2005-01-17 03:16:20 EST
some variables should also be loaded after install:

export PVM_RSH=/usr/bin/ssh
export PVM_ROOT=/usr/share/pvm3
export PVM_ARCH=LINUXI386
export PVM_TMP=/tmp
export PVM_DPATH=$PVM_ROOT/lib/pvmd
Comment 4 Rudi Chiarito 2005-02-01 16:51:50 EST
Straight from the release notes:

"The latest PVM release 3.4.5 is mainly bug fixes and additional
support for varying Linux distributions and some better 64-bit
Linux/AMD support (like it doesn't seg fauly any more :-)."

I can confirm that 3.4.4 runs on x86_64, but segfaults every now and
then. IMHO this is worth an update in FC3 (maybe in updates-testing
first?) and it's not just an enhancement that should target FC4.

As to using ssh by default, some commercial applications are hardwired
to use rsh (I have to struggle constantly with one of those... and the
master process has to run on Windows, which means a flaky rshd, but I
digress). If you are going to enable ssh as the default, I'd put big
warnings in the update notice. Even better, I would postpone that for
the FC4 release. Some surprises are probably to be avoided in the
middle of a release's lifecycle.
Comment 5 Jonathan Underwood 2005-02-01 17:59:19 EST
Agreed with all comments above.

Also, ignore my comment about patching to make ssh the default, that
can be achieved by simply setting the environment variable PVM_RSH as
Comment 3 said.
Comment 6 Jason Vas Dias 2005-02-02 18:21:27 EST
pvm-3.4.5-1 is now in FC4/rawhide, and will shortly be in fc3-updates.
Meanwhile, you can download it from:
  http://people.redhat.com/~jvdias/pvm/FC3

Note You need to log in before you can comment on or make changes to this bug.