Bug 1431833 - Full compatibility of RGW S3 API with S3A
Summary: Full compatibility of RGW S3 API with S3A
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: Vasu Kulkarni
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-13 20:20 UTC by Uday Boppana
Modified: 2017-07-30 15:53 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:30:38 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Uday Boppana 2017-03-13 20:20:50 UTC
Description of problem:
RGW in RHCS 2.3 must work with S3A plugin  in Hadoop 2.7.3 for all HDFS activities.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Kyle Bader 2017-04-19 20:45:11 UTC
RHCS 2.3 passes the S3A unit tests provided by Hadoop 2.7.3

Comment 6 errata-xmlrpc 2017-06-19 13:30:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.