Bug 1431879 - Pre-GDM gnome-initial-setup fails to run (when no user created during install), with log WARNING: Unable to find required component 'gnome-settings-daemon'
Summary: Pre-GDM gnome-initial-setup fails to run (when no user created during install...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 26
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Rui Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F26AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-03-13 23:22 UTC by Adam Williamson
Modified: 2017-03-24 21:53 UTC (History)
12 users (show)

Fixed In Version: gnome-initial-setup-3.24.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-24 21:53:27 UTC
Type: Bug


Attachments (Terms of Use)
system journal from affected system (first boot after install) - use 'journalctl -f system.journal' to view (8.00 MB, application/octet-stream)
2017-03-13 23:24 UTC, Adam Williamson
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 778309 None None None 2019-05-20 08:25:32 UTC
Red Hat Bugzilla 1434154 None CLOSED Pre-GDM gnome-initial-setup fails to run (when no user created during install), with multiple "Unrecoverable failure in ... 2019-05-20 08:25:32 UTC

Internal Links: 1434154

Description Adam Williamson 2017-03-13 23:22:55 UTC
To reproduce:

1. Grab a recent F26 Workstation live (e.g. https://kojipkgs.fedoraproject.org/compose/branched/Fedora-26-20170313.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-26-20170313.n.0.iso )

2. Boot it and do an install, *without* creating a user account during installation

3. Boot the installed system

In multiple attempts across three installs, on two systems (one VM, one bare metal), this consistently results in failure to boot properly, for me: you see the screen flicker several times, then the boot process just seems to hang.

In fact, you can get to a tty and log in and see that the gnome-initial-setup session which should have started up, did not. Additionally, gnome-session-failed then seems to crash, which is https://bugzilla.redhat.com/show_bug.cgi?id=1395968 .

Here are what look like the most relevant log messages:

Mar 13 16:00:25 localhost.localdomain at-spi-bus-launcher[1102]: dbus-daemon[1111]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=988 pid=1097 comm="/usr/libexec/gnome-session-check-accelerated " label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 13 16:00:25 localhost.localdomain ModemManager[793]: <info>  Couldn't check support for device at '/sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0': not supported by any plugin
Mar 13 16:00:25 localhost.localdomain at-spi-bus-launcher[1102]: dbus-daemon[1111]: Successfully activated service 'org.a11y.atspi.Registry'
Mar 13 16:00:25 localhost.localdomain at-spi-bus-launcher[1102]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Mar 13 16:00:25 localhost.localdomain systemd-udevd[1118]: Process '/usr/sbin/crda' failed with exit code 251.
Mar 13 16:00:25 localhost.localdomain gnome-session[1065]: gnome-session-binary[1065]: WARNING: Unable to find required component 'gnome-settings-daemon'
Mar 13 16:00:25 localhost.localdomain gnome-session-binary[1065]: WARNING: Unable to find required component 'gnome-settings-daemon'
Mar 13 16:00:25 localhost.localdomain gnome-session-binary[1065]: Entering running state
Mar 13 16:00:25 localhost.localdomain gnome-session[1065]: Unable to init server: Could not connect: Connection refused
Mar 13 16:00:25 localhost.localdomain audit[1123]: ANOM_ABEND auid=4294967295 uid=988 gid=982 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 pid=1123 comm="gnome-session-f" exe="/usr/libexec/gnome-session-failed" sig=11 res=1
Mar 13 16:00:25 localhost.localdomain dbus-daemon[795]: [system] Activating service name='org.fedoraproject.Setroubleshootd' requested by ':1.23' (uid=0 pid=769 comm="/usr/sbin/sedispatch " label="system_u:system_r:audisp_t:s0") (using servicehelper)
Mar 13 16:00:25 localhost.localdomain systemd-udevd[1124]: Process '/usr/sbin/crda' failed with exit code 251.
Mar 13 16:00:25 localhost.localdomain systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Mar 13 16:00:25 localhost.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@0-1125-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 13 16:00:25 localhost.localdomain systemd[1]: Started Process Core Dump (PID 1125/UID 0).
Mar 13 16:00:25 localhost.localdomain gnome-session[1065]: gnome-session-binary[1065]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Mar 13 16:00:25 localhost.localdomain gnome-session-binary[1065]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Mar 13 16:00:25 localhost.localdomain gnome-session[1065]: gnome-session-binary[1065]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Mar 13 16:00:25 localhost.localdomain gnome-session-binary[1065]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

I'll attach the full journal file for inspection, too.

When you *do* create a user account during installation, the installed system boots successfully to GDM, and the 'user mode' of g-i-s runs correctly after you log in as the created user.

I'm proposing this as an Alpha blocker, per "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility." - https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#Expected_installed_system_boot_behavior

Comment 1 Adam Williamson 2017-03-13 23:24:02 UTC
Created attachment 1262714 [details]
system journal from affected system (first boot after install) - use 'journalctl -f system.journal' to view

Comment 2 Florian Müllner 2017-03-13 23:45:36 UTC
There's an upstream patch available in git, but no tarball release since then ...

Comment 3 Stephen Gallagher 2017-03-14 12:58:52 UTC
FWIW, I think this would fail the "last blocker at Go/No-Go" test, because the "or" phrasing suggests that it only needs to work with either the anaconda or initial-setup tools. (I wish we had metrics on how many people use g-i-s as well).

I'm -1 blocker, but +1 FE (and I'd consider nominating it as a Prioritized Bug as well). I consider this to be a very serious issue, but not a release-blocking one.

Comment 4 Jens Petersen 2017-03-14 13:15:42 UTC
I don't think it boots to either (without user intervention).

Comment 5 Fedora Update System 2017-03-14 18:06:09 UTC
gnome-initial-setup-3.23.92-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e5a6d1bc2c

Comment 6 Kevin Fenzi 2017-03-14 18:51:23 UTC
I'm also -1 blocker (the critera has "or"), but +1 FE and I think we should really try and get this in.

Comment 7 Adam Williamson 2017-03-14 20:44:29 UTC
I believe the intended meaning of the 'or' was "so we aren't requiring a firstboot interface to appear if a user was creating during install", but I'd have to go back and check to be sure. I don't *think* it was intended to allow this kind of dodge.

Comment 8 Adam Williamson 2017-03-15 02:00:13 UTC
g-i-s still doesn't seem to start successfully with gnome-initial-setup-3.23.92-1.fc26 , though the failure mode is different: there's no rapid restarts of X, it just tries to start up once and sticks at a black screen for several minutes, then seems to fail and try again.

Looking at the logs, things look a lot like https://bugzilla.gnome.org/show_bug.cgi?id=674885 :

Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Sharing.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Sharing.desktop
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Sharing.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.ScreensaverProxy.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: Unrecoverable failure in required component org.gnome.SettingsDaemon.ScreensaverProxy.desktop
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.ScreensaverProxy.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Rfkill.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Rfkill.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Rfkill.desktop
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.PrintNotifications.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.PrintNotifications.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: Unrecoverable failure in required component org.gnome.SettingsDaemon.PrintNotifications.desktop
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Power.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: WARNING: Application 'org.gnome.SettingsDaemon.Power.desktop' failed to register before timeout
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session-binary[1429]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Power.desktop
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: Unable to init server: Could not connect: Connection refused
Mar 14 20:55:18 localhost-live.happyassassin.net audit[1711]: ANOM_ABEND auid=4294967295 uid=988 gid=982 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 pid=1711 comm="gnome-session-f" exe="/usr/libexec/gnome-session-failed" sig=11 res=1
Mar 14 20:55:18 localhost-live.happyassassin.net gnome-session[1429]: Unable to init server: Could not connect: Connection refused
Mar 14 20:55:18 localhost-live.happyassassin.net kernel: show_signal_msg: 72 callbacks suppressed
Mar 14 20:55:18 localhost-live.happyassassin.net kernel: gnome-session-f[1711]: segfault at 0 ip 00007fba153cd8d9 sp 00007ffc60809e40 error 4 in libgtk-3.so.0.2200.9[7fba150ed000+6f5000]

That all happens some time after g-i-s tried to start up (which was around 20:53:39), and as you can see at the end, gnome-session-failed crashes again.

Comment 9 Adam Williamson 2017-03-15 02:02:10 UTC
We have sufficient votes for accepted FE status at present.

Comment 10 Fedora Update System 2017-03-15 04:24:30 UTC
gnome-initial-setup-3.23.92-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e5a6d1bc2c

Comment 11 Jeremy Bicha 2017-03-16 06:41:43 UTC
By the way, I am able to duplicate this bug (New User mode fails to start) on Ubuntu GNOME 17.04 Beta with gnome-initial-setup 3.23.92 and gnome-settings-daemon 3.23.92. (Ubuntu GNOME does not use gnome-initial-setup's New User mode by default.)

https://git.gnome.org/browse/gnome-settings-daemon/commit/?id=e5c6735c6b
did not help.

I was able to workaround this by reducing the final line of
/usr/share/gnome-session/sessions/gnome-initial-setup.session

to

RequiredComponents=setup-shell;gnome-initial-setup;org.gnome.SettingsDaemon.Keyboard;org.gnome.SettingsDaemon.Power;

Obviously, that's bad as it disables accessibility support and probably some other important things. But if you need a quick workaround, maybe that will do.

Comment 12 Mike Ruckman 2017-03-16 18:07:47 UTC
Discussed in today's Go/No-Go meeting. This bug is a violation of the following criterion: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."

Comment 13 Yanko Kaneti 2017-03-16 18:14:05 UTC
FWIW since the last time the issue of failing session startup came up for me 3 months ago, I've been running with the dconf workaround (https://git.gnome.org/browse/dconf/commit/?id=701d19d12d4e0599340c9bd1eb2b3e25a40d780b) and I've not had it since.

Comment 14 Jeremy Bicha 2017-03-16 20:15:25 UTC
Yanko, ok that's a similar fix to the gnome-settings-daemon fix and that one doesn't fix Initial Setup for me either.

Comment 15 Mike Ruckman 2017-03-20 17:43:39 UTC
I still see this with the latest RC1 on bare metal.

Comment 16 Adam Williamson 2017-03-20 20:00:02 UTC
So I think we should probably separate the subsequent bug into a separate report for clarity; I'll do that. This bug should track only the first cause of failure, which does indeed seem to be fixed by 3.23.92.

Comment 17 Jeremy Bicha 2017-03-20 20:05:59 UTC
The first part of this bug was fixed with
https://git.gnome.org/browse/gnome-initial-setup/commit/?id=d2c051c12

Comment 18 Adam Williamson 2017-03-20 20:14:14 UTC
Filed https://bugzilla.redhat.com/show_bug.cgi?id=1434154 for the follow-up issue.

Comment 19 Fedora Update System 2017-03-21 19:04:17 UTC
gnome-initial-setup-3.24.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-559925b8d4

Comment 20 Fedora Update System 2017-03-22 15:28:16 UTC
gnome-initial-setup-3.24.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-559925b8d4

Comment 21 Adam Williamson 2017-03-22 21:12:49 UTC
Confirmed this and https://bugzilla.redhat.com/show_bug.cgi?id=1434154 are both fixed in Alpha RC2.

Comment 22 Fedora Update System 2017-03-24 21:53:27 UTC
gnome-initial-setup-3.24.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.