Bug 1431969 - pull gluster-block v0.1.1 into d.g.o
Summary: pull gluster-block v0.1.1 into d.g.o
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-14 07:56 UTC by Prasanna Kumar Kalever
Modified: 2017-03-17 09:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-17 09:13:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2017-03-14 07:56:56 UTC
Description of problem:
same as subject

There was some initiator side login issue found on fedora 25 machine with fqdn portal creation.

Patch [1] should fix this issue. 
I have made a copr build including this patch here [2].

It will be good to make this available in d.g.o before some random user hit the issue.


[1] https://review.gluster.org/#/c/16894/
[2] https://copr.fedorainfracloud.org/coprs/pkalever/gluster-block/build/525645/

Comment 1 Nigel Babu 2017-03-14 08:57:38 UTC
Can you bump up the version to 0.2 please? That way users on 0.1 can upgrade to this one.

Comment 2 Prasanna Kumar Kalever 2017-03-15 06:29:23 UTC
Hi Nigel,

As this doesn't fall under a major fix in v0.1 we would like to go with the release 2 of 0.1 version.

I got an opportunity to raise your thought with block team yesterday and the team think this should be pushed as v0.1-2.

Thanks!

Comment 3 Nigel Babu 2017-03-15 07:17:10 UTC
okay so we currently have: 
https://download.gluster.org/pub/gluster/gluster-block/0.1/

The new release will be:
https://download.gluster.org/pub/gluster/gluster-block/0.1-2/

Would it make sense instead to do 0.1.1 instead? This way you can use the dashed numbers as numbers for the build in case there are build failures on your first attempt.

Happy to go with 0.1-2 as well. Let me know which works best.

Comment 4 Prasanna Kumar Kalever 2017-03-15 07:22:56 UTC
So if you see the package name here [1] it is gluster-block-0.1-1.x86_64.rpm

The new package name will be gluster-block-0.1-2.x86_64.rpm

So ideally, the new path should be https://download.gluster.org/pub/gluster/gluster-block/0.1-2/


Thoughts ?


[1] https://download.gluster.org/pub/gluster/gluster-block/0.1/fedora/25/x86_64/

Comment 5 Anoop C S 2017-03-15 07:27:11 UTC
(In reply to Prasanna Kumar Kalever from comment #4)
> So if you see the package name here [1] it is gluster-block-0.1-1.x86_64.rpm
> 
> The new package name will be gluster-block-0.1-2.x86_64.rpm
> 
> So ideally, the new path should be
> https://download.gluster.org/pub/gluster/gluster-block/0.1-2/

Why should this be under different directory? I would say we put new rpms under 0.1 directory itself i.e, https://download.gluster.org/pub/gluster/gluster-block/0.1/fedora/25/x86_64/

> 
> 
> Thoughts ?
> 
> 
> [1]
> https://download.gluster.org/pub/gluster/gluster-block/0.1/fedora/25/x86_64/

Comment 6 Nigel Babu 2017-03-15 07:33:52 UTC
Different directories makes it cleaner to download the latest package and also use the older packages. Wouldn't that be less confusing?

My knowledge around rpm repos aren't perfect, so happy to be proven wrong here.

Comment 7 Prasanna Kumar Kalever 2017-03-15 07:40:19 UTC
+1 Nigel.

I am okay this way either.

Comment 8 Nigel Babu 2017-03-15 10:01:34 UTC
This is now sorted: https://download.gluster.org/pub/gluster/gluster-block/

I've also setup this repo file: https://download.gluster.org/pub/gluster/gluster-block/gluster-block.repo

If users have that installed, they can download be on the latest version as we release it.

Comment 9 Prasanna Kumar Kalever 2017-03-17 09:01:19 UTC
I must apologies for wrong package name.

Thanks to Kaleb, Niels as well as Nigel for corrected me.

In "0.1-2" the "-2" belongs to revision. Means every time we build a package we do increment this, or if we have build failures due to spec issue we do modify the spec and increment the post-fix.

Since there are code changes, this release should go with 0.1.1 tag.

So now we have to change the 0.1-2 to 0.1.1, Nigel will I get your support here ?

Comment 10 Prasanna Kumar Kalever 2017-03-17 09:02:37 UTC
copr link to package https://copr.fedorainfracloud.org/coprs/pkalever/gluster-block/build/527601/

Comment 11 Nigel Babu 2017-03-17 09:13:15 UTC
This has been done. I've confirmed that upgrades from 0.1-2 to 0.1.1 works from the d.g.o page. All seems to be working well.


Note You need to log in before you can comment on or make changes to this bug.