Bug 143218 - modprobe: Can't locate module sk98lin
modprobe: Can't locate module sk98lin
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 10:52 EST by Tim Scofield
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 17:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Scofield 2004-12-17 10:52:18 EST
Description of problem:
"modprobe sk98lin" returns "modprobe: Can't locate module sk98lin"

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.0.1.EL


How reproducible:
every time


Steps to Reproduce:
1. /sbin/modprobe sk98lin
2.
3.
  
Actual results:
modprobe: Can't locate module sk98lin

Expected results:
module loaded

Additional info:
[root@twscofi1 configs]# uname -svrip
Linux 2.4.21-20.0.1.ELsmp #1 SMP Wed Nov 24 20:26:12 EST 2004 x86_64
x86_64
[root@twscofi1 configs]# grep -i sk98lin
/usr/src/linux-2.4/configs/kernel-2.4.21-x86_64*
/usr/src/linux-2.4/configs/kernel-2.4.21-x86_64.config:CONFIG_SK98LIN=m
/usr/src/linux-2.4/configs/kernel-2.4.21-x86_64-smp.config:CONFIG_SK98LIN=m
Comment 1 Tim Scofield 2004-12-17 14:10:21 EST
find /lib/modules/2.4.21-20.0.1.ELsmp/kernel -name"sk98lin*" does not
find any files. The module doesn't exist in the stock kernel

Compiling a new kernel using "make oldconfig" will generate the
modules, but it hangs while detecting new hardware during boot.
Comment 2 Ernie Petrides 2004-12-17 17:18:16 EST
It's in the associated "kernel unsupported" package.  If you are using
kernel-smp-2.4.21-20.0.1.EL.x86_64.rpm as your base kernel RPM, then
install kernel-smp-unsupported-2.4.21-20.0.1.EL.x86_64.rpm as well.

Since the sk98lin is unsupported, we have no idea if it will actually
work.  And naturally, if it doesn't, you'll have to resolve any problems
with it yourself.

Note You need to log in before you can comment on or make changes to this bug.