Bug 1432188 - Nodes registration never ends until the window is refreshed
Summary: Nodes registration never ends until the window is refreshed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Dan Trainor
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-14 18:08 UTC by Ola Pavlenko
Modified: 2017-05-17 20:07 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-ui-3.1.0-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:07:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 453127 None None None 2017-04-05 13:45:42 UTC
OpenStack gerrit 453742 None None None 2017-04-06 15:06:08 UTC
OpenStack gerrit 453743 None None None 2017-04-06 15:05:50 UTC
OpenStack gerrit 453790 None None None 2017-04-06 15:05:15 UTC
Launchpad 1672826 None None None 2017-03-14 18:13:06 UTC

Description Ola Pavlenko 2017-03-14 18:08:51 UTC
Description of problem:
Nodes registration seems never end until the window is refreshed

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. upload instackenv.json
2. click on register 
3. wait for nodes table to view new registered nodes

Actual results:
nodes registration spin forever until the page refreshed 

Expected results:
after new nodes were registered, registered nodes table is shown with each nodes' statuses

Additional info:
while nodes registration still "in progress" on UI , in CLI nodes info already available:

[stack@lynx02 ~]$ openstack baremetal node list
+--------------------------------------+------------------------------------------------------------------------+---------------+-------------+--------------------+-------------+
| UUID                                 | Name                                                                   | Instance UUID | Power State | Provisioning State | Maintenance |
+--------------------------------------+------------------------------------------------------------------------+---------------+-------------+--------------------+-------------+
| f660285d-d50f-4ff4-a90b-3eff09173bf1 | Lynx01                                                                 | None          | power off   | manageable         | False       |
| 41fb2ac5-261d-4028-bc38-40455335b929 | Lynx03                                                                 | None          | power off   | manageable         | False       |
| 43587305-9e10-444b-b3f4-7ac04f03bf75 | lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx | None          | power off   | manageable         | False       |
|                                      | 04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04ly |               |             |                    |             |
|                                      | nx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04lynx04 |               |             |                    |             |
|                                      | lynx04lynx04lynx04lynx04lynx04lynx04lynx04lyl                          |               |             |                    |             |
| d0ad2c6d-7d70-418a-a928-cf8e5ce69c59 | ~                                                                      | None          | power off   | manageable         | False       |
| c3a0205b-95f4-48c7-892e-298c6c7c1590 | Lynx16                                                                 | None          | power off   | manageable         | False       |
| 06bb48a2-384d-4786-a85b-8f2834eed469 | ~Lynx17                                                                | None          | power off   | manageable         | False       |
+--------------------------------------+------------------------------------------------------------------------+---------------+-------------+--------------------+-------------+

Comment 1 Ola Pavlenko 2017-03-14 18:09:06 UTC
openstack-tripleo-ui-3.1.0-2.el7ost.noarch

Comment 2 Dan Trainor 2017-03-23 22:19:47 UTC
I was not able to reproduce this with openstack-tripleo-ui-3.1.0-4.el7ost.noarch, is it something you can re-attempt with this version?  I'm using the 2017-03-22.1 puddle.

Comment 8 Jason E. Rist 2017-04-03 15:07:16 UTC
https://review.openstack.org/#/c/452017

Comment 9 Jason E. Rist 2017-04-05 13:44:33 UTC
https://review.openstack.org/#/c/453127

Comment 10 Jiri Tomasek 2017-04-05 13:56:02 UTC
This bug still occurs even with above change applied, there is a bug in GUI which causes this problem. Fixes are avialable in this patchset:
https://review.openstack.org/#/c/453469/ (+ 2 dependent patches)

Comment 13 Ola Pavlenko 2017-04-09 05:11:43 UTC
Verified openstack-tripleo-ui-3.1.0-8.el7ost.noarch

Comment 17 errata-xmlrpc 2017-05-17 20:07:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.