Bug 1432200 (CVE-2017-2994, CVE-2017-2997, CVE-2017-2998, CVE-2017-2999, CVE-2017-3000, CVE-2017-3001, CVE-2017-3002, CVE-2017-3003) - CVE-2017-2994 CVE-2017-2997 CVE-2017-2998 CVE-2017-2999 CVE-2017-3000 CVE-2017-3001 CVE-2017-3002 CVE-2017-3003 flash-plugin: multiple code execution issues fixed in APSB17-07
Summary: CVE-2017-2994 CVE-2017-2997 CVE-2017-2998 CVE-2017-2999 CVE-2017-3000 CVE-201...
Status: CLOSED ERRATA
Alias: CVE-2017-2994, CVE-2017-2997, CVE-2017-2998, CVE-2017-2999, CVE-2017-3000, CVE-2017-3001, CVE-2017-3002, CVE-2017-3003
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=critical,public=20170314,repor...
Keywords: Security
Depends On: 1432202 1432203
Blocks: 1432201
TreeView+ depends on / blocked
 
Reported: 2017-03-14 18:37 UTC by Tomas Hoger
Modified: 2019-06-08 21:51 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-03-15 12:37:21 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0526 normal SHIPPED_LIVE Critical: flash-plugin security update 2017-03-15 16:20:45 UTC

Description Tomas Hoger 2017-03-14 18:37:42 UTC
Adobe Security Bulletin APSB17-07 for Adobe Flash Player describes multiple flaws that can possibly lead to code execution when Flash Player is used to play a specially crafted SWF file.

Quoting from the APSB17-07:

These updates resolve a buffer overflow vulnerability that could lead to code execution (CVE-2017-2997).

These updates resolve memory corruption vulnerabilities that could lead to code execution (CVE-2017-2998, CVE-2017-2999).

These updates resolve a random number generator vulnerability used for constant blinding that could lead to information disclosure (CVE-2017-3000).

These updates resolve use-after-free vulnerabilities that could lead to code execution (CVE-2017-3001, CVE-2017-3002, CVE-2017-3003).

External References:

https://helpx.adobe.com/security/products/flash-player/apsb17-07.html

Comment 2 errata-xmlrpc 2017-03-15 12:20:54 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6 Supplementary

Via RHSA-2017:0526 https://rhn.redhat.com/errata/RHSA-2017-0526.html

Comment 3 Martin Prpič 2017-04-18 08:37:22 UTC
Adding CVE-2017-2994:

https://helpx.adobe.com/security/products/flash-player/apsb17-07.html#Revisions


Note You need to log in before you can comment on or make changes to this bug.