Bug 143222 - xconfig causes "Red Hat Ready" kickstart to reboot on Unisys ES7000/540
xconfig causes "Red Hat Ready" kickstart to reboot on Unisys ES7000/540
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: ispec (Show other bugs)
beta
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Will Woods
Rob Landry
:
Depends On:
Blocks: 137160 142571 143442
  Show dependency treegraph
 
Reported: 2004-12-17 11:17 EST by Daniel W. Ottey
Modified: 2007-04-18 13:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 17:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screen capture of the error (28.36 KB, image/png)
2004-12-17 11:19 EST, Daniel W. Ottey
no flags Details

  None (edit)
Description Daniel W. Ottey 2004-12-17 11:17:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
We are attempting to run the "Red Hat Ready" beta hardware 
certification on our Unisys ES7000/540 system, installing RHEL4.

The hardware certification creates a kickstart file with the 
following line in it:
xconfig --depth=16 --resolution=1024x768 --defaultdesktop=GNOME

When this command runs on our system, anaconda reports an error and 
reboots.  There is no way to capture the log, but I have gotten a 
screen capture.

We narrowed the problem to this command because the error goes away 
when we change the "xconfig" line to "skipx."

The Unisys ES7000/540 uses a proprietary video controller 
called "Console Manager 2" that enables remote viewing of system 
video.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use "Red Hat Ready" beta hardware certification on an ES7000/540
2.
3.
    

Actual Results:  System reboots

Expected Results:  No error

Additional info:
Comment 1 Daniel W. Ottey 2004-12-17 11:19:00 EST
Created attachment 108804 [details]
A screen capture of the error

I apologize for the poor quality of this screen capture.  I do not know how to
capture the logs of this error, since the system reboots automatically.  If you
can tell me how to further gather data, I would be happy to do so.
Comment 2 Mike A. Harris 2004-12-17 19:05:08 EST
The error message is from anaconda, the system installer.  Reassigning
to the 'anaconda' component, for review of the traceback.


(P.S.  XFree86 has been replaced by X.Org X11 in Red Hat Enterprise
 Linux 4 beta, which is the "xorg-x11" component in bugzilla.)
Comment 3 Jeremy Katz 2004-12-20 13:11:07 EST
The hwcert tests are assuming pc-like hardware and thus try to
configure X for the machine.  This isn't entirely accurate for the
unisys boxes which are headless.
Comment 4 Rob Landry 2004-12-20 16:52:36 EST
rhr2 hasn't started yet; instead it appears ispec isn't accounting for
zero heads or user error in the spec submission where more than zero
heads where assigned.
Comment 5 Richard Li 2004-12-20 17:16:21 EST
This is a bug in iSpec. Your workaround in changing the kickstart file is
correct. Reassign to wwoods to fix in iSpec's ks generation (and UI, since the
UI assumes at least 1 head if a video controller is present).
Comment 6 Will Woods 2005-01-03 16:30:44 EST
Code is in CVS that does the following:

- change UI to allow headless video controllers (i.e. allow heads=0)
- only run VIDEO if testing a video controller that supports one or more heads
- ks.cfg now only includes 'xconfig' if we are running the VIDEO test

Comment 8 Richard Li 2005-01-06 09:38:03 EST
i've verified on my test case. marking QA_READY for verification by unisys.
Comment 9 Daniel W. Ottey 2005-01-06 10:45:30 EST
We would be happy to test/verify this.  Could I please be pointed in the
direction of the CVS server (if available), or another location for download of
this latest version?
Comment 10 Richard Li 2005-01-06 10:50:49 EST
Oops, that would help ;-). I've put a temporary RPM up here:

http://people.redhat.com/richardl/ispec-0.96-1.12.noarch.rpm

(You should be able to rpm -Uvh the RPM and choose 0 for number of video
controllers).
Comment 11 Jay Turner 2005-02-10 07:11:41 EST
Any feedback here?
Comment 12 Daniel W. Ottey 2005-02-10 08:58:10 EST
Seems to work well.  Thanks.
Comment 13 Jay Turner 2005-02-28 07:23:49 EST
Placing in PROD_READY based on comment 12.

Note You need to log in before you can comment on or make changes to this bug.