Bug 1432247 - KDE Plasma File View desktop icons stay highlighted after mouse-over
Summary: KDE Plasma File View desktop icons stay highlighted after mouse-over
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-14 21:56 UTC by Mace Moneta
Modified: 2017-03-16 22:21 UTC (History)
6 users (show)

Fixed In Version: plasma-workspace-5.8.6-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 22:34:10 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of multiple icons with stuck highlight (1.03 MB, image/png)
2017-03-14 22:12 UTC, Mace Moneta
no flags Details

Description Mace Moneta 2017-03-14 21:56:32 UTC
Description of problem:

I installed a clean system using image:

Fedora-KDE-Live-x86_64-25-1.3.iso

Moving the mouse over desktop icons highlighted them, and moving the mouse off removed the highlight.

Applied all maintenance to bring the system to current. Rebooted.

Now, when I mouse-over a desktop icon, it highlights. Moving the mouse off the icon does not remove the highlight. Moving the mouse of other icons highlights them as well. All icons remain highlighted, until the plasma-shell is restarted.


Version-Release number of selected component (if applicable):

plasma-workspace-5.8.6-3.fc25.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Install Fedora KDE spin
2. Apply maintenance
3. Reboot

Actual results:

Desktop icons stay highlighted as the mouse passes over them.

Expected results:

The highlight should be removed when the mouse is no longer over the icon.

Additional info:

Comment 1 Mace Moneta 2017-03-14 22:12:23 UTC
Created attachment 1263057 [details]
Screenshot of multiple icons with stuck highlight

Also, tried downgrading plasma-workspace (and requisites) and rebooting; no change.

Comment 2 Fedora Update System 2017-03-14 22:18:23 UTC
plasma-desktop-5.8.6-3.fc25 plasma-workspace-5.8.6-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d83ef1742d

Comment 3 Mace Moneta 2017-03-14 22:25:26 UTC
Updated to plasma-workspace-5.8.6-4.fc25 (plus requisites) from updates-testing. No change.

Comment 4 Rex Dieter 2017-03-14 22:26:02 UTC
and plasma-desktop ?

Comment 5 Rex Dieter 2017-03-14 22:26:30 UTC
(and you'll likely need to restart your session after update as well, if not obvious)

Comment 6 Mace Moneta 2017-03-14 22:34:10 UTC
Updated plasma-desktop to 5.8.6-3 from updates-testing and the problem is resolved. Thanks!

Comment 7 Fedora Update System 2017-03-16 22:21:58 UTC
plasma-desktop-5.8.6-3.fc25, plasma-workspace-5.8.6-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.