Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1432283 - pcs hides debugging options for (some?) fencing devices
pcs hides debugging options for (some?) fencing devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tomas Jelinek
cluster-qe@redhat.com
Steven J. Levine
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-14 21:17 EDT by Andrew Beekhof
Modified: 2018-04-10 11:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: pcs-0.9.160-1.el7
Doc Type: Bug Fix
Doc Text:
It is now possible to enable stonith agent debugging without specifying the `--force` flag Previously, attempting to enable debugging of a stonith agent by setting the `debug` or `verbose` parameters required that the user specify the `--force` flag. With this fix, using the `--force` flag is no longer necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:39:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix + tests (4.94 KB, patch)
2017-06-12 07:33 EDT, Tomas Jelinek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0866 None None None 2018-04-10 11:40 EDT

  None (edit)
Description Andrew Beekhof 2017-03-14 21:17:48 EDT
Description of problem:

[root@overcloud-controller-0 heat-admin]# crm_resource --show-metadata stonith:fence_ipmilan | grep -e verbose -e debug
    <parameter name="verbose" unique="0" required="0">
    <parameter name="debug" unique="0" required="0">
      <getopt mixed="-d [pathtodebugfile]           Path to debug file"/>
        Path to debug file
[root@overcloud-controller-0 heat-admin]# pcs stonith describe fence_ipmilan | grep -e verbose -e debug
[root@overcloud-controller-0 heat-admin]#


Version-Release number of selected component (if applicable):

pcs-0.9.152-10.el7.centos.3.x86_64

How reproducible:

100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Tomas Jelinek 2017-06-12 07:33 EDT
Created attachment 1287034 [details]
proposed fix + tests
Comment 4 Ivan Devat 2017-10-11 03:53:37 EDT
After Fix:

[vm-rhel72-1 ~] $ rpm -q pcs
pcs-0.9.160-1.el7.x86_64

[vm-rhel72-1 ~] $ pcs stonith create S fence_apc login=l ipaddr=i verbose=v debug=d
[vm-rhel72-1 ~] $ pcs cluster cib --config | grep 'id="S"' -A10
    <primitive class="stonith" id="S" type="fence_apc">
      <instance_attributes id="S-instance_attributes">
        <nvpair id="S-instance_attributes-debug" name="debug" value="d"/>
        <nvpair id="S-instance_attributes-ipaddr" name="ipaddr" value="i"/>
        <nvpair id="S-instance_attributes-login" name="login" value="l"/>
        <nvpair id="S-instance_attributes-verbose" name="verbose" value="v"/>
      </instance_attributes>
      <operations>
        <op id="S-monitor-interval-60s" interval="60s" name="monitor"/>
      </operations>
    </primitive>
Comment 11 errata-xmlrpc 2018-04-10 11:39:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0866

Note You need to log in before you can comment on or make changes to this bug.