Bug 1432459 - Revert the changes introduced in cns-deploy for storing heketi db in kube secret.
Summary: Revert the changes introduced in cns-deploy for storing heketi db in kube se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.5
Assignee: Michael Adam
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1415600
TreeView+ depends on / blocked
 
Reported: 2017-03-15 12:31 UTC by Humble Chirammal
Modified: 2018-12-06 19:35 UTC (History)
6 users (show)

Fixed In Version: cns-deploy-4.0.0-3.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:27:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Humble Chirammal 2017-03-15 12:31:56 UTC
Description of problem:

In Heketi v4, the DB is also stored in Kube Secret. It may cause issues especially in CNS or scaled setups.  We need to revisit this DB migration introduced in Heketi v4 release and revert the changes in cns-deploy script.

Version-Release number of selected component (if applicable):

cns-deploy v1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Humble Chirammal 2017-03-15 12:35:58 UTC
Upstream PR # https://github.com/gluster/gluster-kubernetes/pull/200

Comment 6 Prasanth 2017-04-06 13:38:12 UTC
Verified

Comment 7 errata-xmlrpc 2017-04-20 18:27:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112

Comment 8 vinutha 2018-12-06 19:35:59 UTC
Marking qe-test-coverage as - since the preferred mode of deployment is using ansible


Note You need to log in before you can comment on or make changes to this bug.