Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1432505 - alter GNOME in such a way that it /does/ load a custom overrides file for a mode, presumably reading the modes/name.json file and using the contents of the 'overridesSchema' option.
alter GNOME in such a way that it /does/ load a custom overrides file for a m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1420851 1479818
  Show dependency treegraph
 
Reported: 2017-03-15 10:26 EDT by Ajinkya Patil
Modified: 2018-05-17 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:55:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 751921 None None None 2017-07-27 04:25 EDT
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 08:57 EDT

  None (edit)
Description Ajinkya Patil 2017-03-15 10:26:18 EDT
Description of problem:
alter GNOME in such a way that it /does/ load a custom overrides file for a mode, presumably reading the modes/name.json file and using the contents of the 'overridesSchema' option.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Its related to 
https://bugzilla.gnome.org/show_bug.cgi?id=751921
https://git.gnome.org/browse/gnome-shell/commit/?id=dfc4cc4aafd1ca3dd5257341
Comment 2 Florian Müllner 2017-03-16 13:47:47 EDT
(In reply to Ajinkya Patil from comment #0)
> Description of problem:
> alter GNOME in such a way that it /does/ load a custom overrides file for a
> mode, presumably reading the modes/name.json file and using the contents of
> the 'overridesSchema' option.

This was removed for a reason:
https://git.gnome.org//browse/gnome-shell/commit?id=ae2751a68b20ab281ca74affd61562fb8869b639

We really want to initialize the overrides before handling control over to the javascript code, or those issues will be back. It would be possible to have a small javascript hook to retrieve the setting, do the initialization in C, and then start the "real" javascript code, but that's quite horrible (we'd be starting the javascript engine, looking for session mode files in the filesystem, and loading and parsing them *twice* on startup).

A far less intrusive alternative would be to allow setting a custom overrides schema via an environment variable or command line switch.
Comment 3 David Bell 2017-03-23 06:44:59 EDT
(In reply to Florian Müllner from comment #2)
> A far less intrusive alternative would be to allow setting a custom
> overrides schema via an environment variable or command line switch.

That would be great - we're creating a new X session anyway, so we can set a variable or command line switch (which is already done to set the mode).
Comment 4 Ajinkya Patil 2017-07-23 21:22:55 EDT
Hello,

When can we expect a fix?

Thanks,
Ajinkya Patil
Comment 7 Florian Müllner 2017-10-26 12:43:54 EDT
The latest RHEL 7.5 build adds an --override-schema option as requested.
Comment 12 errata-xmlrpc 2018-04-10 08:55:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.