Bug 1432562 - Memtest86+ reports false positive memory errors
Summary: Memtest86+ reports false positive memory errors
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: memtest86+
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-15 16:58 UTC by Marc Muehlfeld
Modified: 2017-12-12 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:45:06 UTC


Attachments (Terms of Use)
Screenshot (one run of test 7) (171.42 KB, image/jpeg)
2017-03-15 16:58 UTC, Marc Muehlfeld
no flags Details
Screenshot (188.34 KB, image/jpeg)
2017-03-15 17:02 UTC, Marc Muehlfeld
no flags Details
Screenshot with SMP disabled (143.15 KB, image/jpeg)
2017-03-15 17:11 UTC, Marc Muehlfeld
no flags Details

Description Marc Muehlfeld 2017-03-15 16:58:09 UTC
Created attachment 1263397 [details]
Screenshot (one run of test 7)

Description of problem:
When I run Memtest86+ 5.01 on my new computer, the utility reports in almost each run 32 errors in test 7 (block move). I think it must be a false positive, because:

* I have two equal memory modules, I tested separately. For both test 7 fails and all errors are within the first 1 MB. First I thought the modules are broken and asked Kingston to replace them. However, even for the new ones the same problems are reported. I think it's very unlikely that 4 modules have exactly the same problem.

* The mainboard vendor officially list the memory module as compatible.

* The same problem was reported for Passmark Memtest86 in 2013:
  http://www.passmark.com/forum/memtest86/4281-consistent-error-but-only-one-test-6-and-only-w-parallel-cpu-real-problem#post25250
  They fixed the problem with a workaround (see comment 15). See also the background details in the release notes linked in this comment.

* I run Memtest 86 7.3 Free Edition 4 hours (4 runs) and no errors were found. Also memtester, did not find any problems.



Version-Release number of selected component (if applicable):
memtest86+ 5.01



How reproducible:
Always.



Steps to Reproduce:
1. Boot PC with one or both RAM modules into Memtest86+
2. Wait until test 7 is executed.
   Alternatively you can only select test 7 and limit the test range from 0 to 1 MB.



Actual results:
32 errors are reported in almost every run.



Expected results:
No errors should be shown if the hardware is OK.



Additional info:
Hardware:
  Mainboard: Gigabyte GA-Z270-HD3P, BIOS F4 (previously F2)
  CPU: Intel i7-7700
  RAM: Kingston HyperX HX424C15FB/16
Gigabyte officially lists the CPU and the RAM modules as compatible.

I also tested it after resetting the BIOS to defaults.

Comment 1 Marc Muehlfeld 2017-03-15 17:02:45 UTC
Created attachment 1263399 [details]
Screenshot

This is how it looks if I only run "test 7" and only on the reported area (0 - 1MB) for more than 10000 loops.

Comment 2 Marc Muehlfeld 2017-03-15 17:11:42 UTC
Created attachment 1263400 [details]
Screenshot with SMP disabled

If I disable SMP, no errors are reported (not even after 6400 passes).

This sounds like the same problem that was fixed in Passmark Memtest86. See #c0.

Comment 3 Jaroslav Škarvada 2017-03-15 17:37:19 UTC
Thanks for info, but it seems like HW problem, from the Passmark release notes:

---
It turned out the problem was more elusive that we expected. Basically when multiple threads are running the CPU registers get corrupted. They appear to spontaneously become corrupted during the test. Causing a flood of errors. People generally encountered the problem at Test #3 as this was the first test to use multi-threading. But the other tests had similar problems. We don't know if this is a CPU errata, a bug in the way multi-threading is setup, non maskable hardware interrupts messing up the CPU's state or something more subtle. Part of the problem is also that the available debugging techniques (as MemTest86 runs without having an operating system being loaded) are extremely basic. Debugging the code probably even worse than it was in the DOS3.3 days.

So the work-around implemented was to change the default CPU selection mode to round robin. In this mode only one CPU is used at a time, but after each test the CPU in use is rotated. So all CPUs will still get used, but only after a longer period of time.
---

If I understand it correctly the workaround consists in effectively turning multi-threaded test to single-threaded? Too bad. Unfortunately I do not have the affected HW so I cannot look onto it myself. Also if I am not mistaken the default running mode in Fedora is single core, so you shouldn't encounter the problem if you use the default mode. The SMP mode is still experimental and needs to be explicitly selected.

Comment 4 Fedora End Of Life 2017-11-16 19:48:36 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2017-12-12 10:45:06 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.