Bug 1432565 - python-rosinstall: python3-rosinstall is missing Python 3 version of executables
Summary: python-rosinstall: python3-rosinstall is missing Python 3 version of executables
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rosinstall   
(Show other bugs)
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PY3PATCH-AVAILABLE PY3-EXECUTABLES
TreeView+ depends on / blocked
 
Reported: 2017-03-15 17:02 UTC by Iryna Shcherbina
Modified: 2018-05-27 16:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-27 16:59:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Iryna Shcherbina 2017-03-15 17:02:13 UTC
The Python 3 subpackage  python3-rosinstall is missing executables available in the Python 2 subpackage.

According to the Fedora Packaging guidelines for Python [0], if a Python package that supports Python 3 installs executables into /usr/bin,  then either both Python versions of the executables should be packaged, or only the Python 3 version, depending on the functionality they provide.
(Note the "should": having Python 2-only executables is permitted, but strongly discouraged.)

Is it intentional for this particular package?

In case it is not intentional, please provide a Python 3 version of executable, or you can just switch to Python 3 if the functionality is the same regardless of the Python version. The guide for porting Python-based RPMs is available here [1] and you may refer to it for more instructions.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 26 as well.

If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing the issue!

[0] https://fedoraproject.org/wiki/Packaging:Python#Avoiding_collisions_between_the_python_2_and_python_3_stacks
[1] http://python-rpm-porting.readthedocs.io/

Comment 1 Jan Kurik 2017-08-15 08:30:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 2 Jan Beran 2017-08-29 14:36:16 UTC
I created a Pagure PR that fixes the missing Python 3 version of executables:

https://src.fedoraproject.org/rpms/python-rosinstall/pull-request/1

May I ask to review and make the new package?

Thanks.

Comment 3 Jan Beran 2017-09-18 13:26:36 UTC
Hello Rich, please, may I ask for your feedback?

Comment 4 Miro Hrončok 2017-10-12 13:25:16 UTC
I don't know what rosinstall is, but is there a user facing difference between the Python 2 and Python 3 executables? Because if it isn't, the Python 2 executables should go away.

Comment 5 Jan Beran 2017-10-13 07:04:43 UTC
Hi Miro, thanks for the review. I have updated the patch according to your comments in Pagure PR: https://src.fedoraproject.org/rpms/python-rosinstall/pull-request/2

Comment 6 Jan Beran 2018-01-10 07:36:32 UTC
Hello Rich,

please could you review Pagure PR [1] which fixes the missing Python 3 version of executables issue, and rebuild the package?

[1] https://src.fedoraproject.org/rpms/python-rosinstall/pull-request/2

Comment 7 Jan Beran 2018-03-19 09:28:18 UTC
Hello Rich,

I created the updated Pagure PR that fixes the missing Python 3 version of executables:

https://src.fedoraproject.org/rpms/python-rosinstall/pull-request/4

May I ask to review and make the new package?

Comment 8 Rich Mattes 2018-05-27 16:59:48 UTC
Looks good, I merged and built in rawhide.


Note You need to log in before you can comment on or make changes to this bug.