Bug 1432630 - python2-jinja2 needed for python2-ipaclient
Summary: python2-jinja2 needed for python2-ipaclient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Scott Poore
URL:
Whiteboard:
Depends On:
Blocks: 1392968
TreeView+ depends on / blocked
 
Reported: 2017-03-15 20:06 UTC by Scott Poore
Modified: 2017-08-01 09:46 UTC (History)
10 users (show)

Fixed In Version: ipa-4.5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Scott Poore 2017-03-15 20:06:10 UTC
Description of problem:

While trying to update ipa-client from 4.4 to 4.5, I'm seeing a missing (or incorrect) dependency:

--> Finished Dependency Resolution
Error: Package: python2-ipaclient-4.5.0-1.el7.noarch (ipa-4.5.0-1)
           Requires: python2-jinja2

I see a python-jinja2 package but, not python2-jinja2.  Is this a missing package or a problem with the python2-ipaclient dependencies?

Version-Release number of selected component (if applicable):
ipa-4.5.0-1

How reproducible:
always in the current repos I'm testing with.

Steps to Reproduce:
1.  yum install ipa-client
2.
3.

Actual results:
--> Finished Dependency Resolution
Error: Package: python2-ipaclient-4.5.0-1.el7.noarch (ipa-4.5.0-1)
           Requires: python2-jinja2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
ipa-client version 4.5.0 installs cleanly.

Additional info:

Comment 9 Scott Poore 2017-03-21 15:42:26 UTC
Verified.

Version ::

ipa-server-4.5.0-2.el7.x86_64


Results ::

Had a clean run of yum install with 4.5.0-2.

# yum install ipa-server

...

Installed:
  ipa-server.x86_64 0:4.5.0-2.el7                                                                    ....  

[root@rhel7-1 ~]# rpm -qa|grep jinja2
python-jinja2-2.7.2-2.el7.noarch

Comment 10 errata-xmlrpc 2017-08-01 09:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.