Bug 1432649 - New packages are not synced from the satellite to capsule even after a successful capsule sync.
Summary: New packages are not synced from the satellite to capsule even after a succes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule - Content
Version: 6.2.7
Hardware: x86_64
OS: Linux
high
urgent vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-15 20:55 UTC by Prakash Ghadge
Modified: 2019-08-12 14:37 UTC (History)
17 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.4, tfm-rubygem-katello-3.0.0.151-1, rubygem-katello-3.0.0.151-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1480356 (view as bug list)
Environment:
Last Closed: 2017-09-25 18:59:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2803 normal SHIPPED_LIVE Satellite 6.2.12 bug fix update 2017-10-12 19:22:49 UTC
Foreman Issue Tracker 19179 None None None 2017-04-05 15:03:11 UTC

Description Prakash Ghadge 2017-03-15 20:55:58 UTC
Description of problem:

New packages are not synced from the satellite to capsule even after a successful capsule sync.

Version-Release number of selected component (if applicable):

Satellite 6.2.7 and capsule 6.2.7 

How reproducible:

Was not able to reproduce locally

Steps to Reproduce:

Actual results:

Sync completes with out any error but no new content is available on capsule server.
~~~
Id: 933e3a70-0f0d-47f0-852a-5bec45004f34
Label: Actions::Katello::CapsuleContent::Sync
Name: Synchronize capsule content
Owner: admin
Execution type: Delayed
Start at: 2017-02-14 16:26:53 UTC
Start before: -
Started at: 2017-02-14 16:26:54 UTC
Ended at: 2017-02-14 16:37:00 UTC
State: stopped
Result: success
~~~

In capsule sync task, if we open any "Actions::Pulp::Consumer::SyncCapsule (success) " task we canclearly see that the sync is succesfully but no new packages are copied over the capsule server.

For example - 
~~~
pulp:repository:DIB-Install-Meta_Capsule_7-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_RPMs_x86_64_7Server
  - pulp:action:sync
.
.
<SNIP>
.
.
details:
          rpm_total: 0  <<--- Count Remains 0 even there are new packages are available to sync
          rpm_done: 0   <<--- Count Remains 0 even there are new packages are available to sync
          drpm_total: 0
          drpm_done: 0
        size_total: 0
        size_left: 0
        items_left: 0
~~~

If we check the /var/lib/pulp/published/yum/master/yum_distributor/ the repository name is identical on both side. But if we check the symlinks and the metadata on capsule server, we can see that the directory still contains the old data. 

Also, locate or find command for package search on file system does not yield any result.

Expected results:

Should sync the latest content on the capsule server.

Additional info:

Comment 8 John Mitsch 2017-04-05 15:03:09 UTC
Created redmine issue http://projects.theforeman.org/issues/19179 from this bug

Comment 13 John Mitsch 2017-07-10 17:25:26 UTC
Hey Saikumar,

The only workarounds that currently exist so far are the ones mentioned above. We are looking into more permanent solutions and alternative workarounds currently.

-John

Comment 15 pm-sat@redhat.com 2017-07-26 18:12:12 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/19179 has been resolved.

Comment 16 pm-sat@redhat.com 2017-08-03 22:14:53 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/19179 has been resolved.

Comment 18 Peter Ondrejka 2017-08-29 13:13:18 UTC
Verifed on satellite-6.2.12-1.0.el7sat.noarch. After syncing the capsule content, the packages synced in the associated LC env can be found in /var/lib/pulp... repositories on capsule.

Comment 20 errata-xmlrpc 2017-09-25 18:59:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803


Note You need to log in before you can comment on or make changes to this bug.