Bug 143280 - label printing broke in 2.4.4p3-1.21as
label printing broke in 2.4.4p3-1.21as
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: amanda (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Jay Turner
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 18:50 EST by Patrick C. F. Ernzer
Modified: 2015-01-07 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 11:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
amanda.conf as requested (18.42 KB, text/plain)
2004-12-18 05:23 EST, Patrick C. F. Ernzer
no flags Details
my lbl-templ (7.35 KB, text/plain)
2004-12-18 05:24 EST, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2004-12-17 18:50:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
since installing 2.4.4p3-1.21as my nightly backups fail to print a
label. The report e-mail states "amreport: ERROR no printer command
defined"

I fail to find a refernce as to what it wants as print command

Version-Release number of selected component (if applicable):
amanda-2.4.4p3-1.21as

How reproducible:
Always

Steps to Reproduce:
1. use amanda-server-2.4.2p2
2. print labels just fine
3. update to amanda-server-2.4.4p3
    

Actual Results:  labels fail to print

Expected Results:  old config still prints labels with the new version

Or a mention in the changelog as to what needs to be changed in the
config.

Explicitly setting a printer in the amanda config did not help either.

Additional info:

using amreport to output to a ps file and using lpr on that file works
just fine.

Maybe I jsut missed something obvious, it is late after all.

http://www.amanda.org/docs/labelprinting.html does not mention a
printing command that would need setting either.

And yes, lbl-templ points to an existing file.
Comment 1 Jay Fenlason 2004-12-17 20:20:47 EST
Please attach your amanda config. (/etc/amanda/*/amanda.conf) 
Comment 2 Patrick C. F. Ernzer 2004-12-18 05:23:40 EST
Created attachment 108842 [details]
amanda.conf as requested

as lbl-templ points to a file that is not part of the amanda-server RPM, I will
attach that as well
Comment 3 Patrick C. F. Ernzer 2004-12-18 05:24:17 EST
Created attachment 108843 [details]
my lbl-templ
Comment 4 Patrick C. F. Ernzer 2004-12-18 05:27:18 EST
using /usr/share/doc/amanda-server-2.4.4p3/examples/HP-DAT.ps (from
amanda-server-2.4.4p3-1.21as) as a lbl-templ does not make a difference
Comment 5 Patrick C. F. Ernzer 2004-12-18 05:42:34 EST
One more thing that just crossed my mind, this AS 2.1 machine has cups
installed (self-built, my whole network here uses cups)

bash-2.05$ which lpr
/usr/bin/lpr
bash-2.05$ rpm -qf `which lpr`
cups-1.1.17-13pcfe

But if this was part of the problem, I would expect something along
the lines of "amreport: ERROR printer command failed" and not
"amreport: ERROR no printer command defined" in the e-mail reports.

Plus, LPRng-3.7.4-28.2 (what we currenly have for AS 2.1) has it's lpr
command in exactly the same spot (according to
https://rhn.redhat.com/network/software/packages/file_list.pxt?pid=88873)
Comment 6 Patrick C. F. Ernzer 2005-01-03 12:03:34 EST
FWIW: rebuilding amanda-2.4.4p3-1.21as.src.rpm on the affected box
solved the problem. I can now do

/usr/sbin/amreport MYBACKUPSET -l
/var/lib/amanda/MYBACKUPSET/log/log.20050103.1

And it will print the label as expected.
Comment 7 Jay Fenlason 2005-01-04 11:31:04 EST
It looks like the buildroots don't have LPRng installed in them, so Amanda's 
configure didn't find the lpr command and disabled banner printing.  If you 
rebuild on a machine with LPRng or cups installed, it'll work.  I'm adding 
BuildRequires LPRng to the spec file and will try rebuilding through beehive. 
Comment 8 Jay Fenlason 2005-01-04 14:59:35 EST
Can you try the amanda-2.4.4p3-1.21as.1 rpms from dist-2.1AS-errata-candidate?  
If they work, I can try to squeeze in a bugfix erratum for the next RHEL-2.1 
update. 
Comment 9 Patrick C. F. Ernzer 2005-01-05 05:15:55 EST
confirm

amanda-2.4.4p3-1.21as.1 from dist-2.1AS-errata-candidate allows me to print a
report just fine with

/usr/sbin/amreport MYBACKUPSET -l
/var/lib/amanda/MYBACKUPSET/log/log.20050105.0

I'll nag tomorrow if (against all expectations) there should be a failure with
the automatic post-backup printing.

If you have not heard bacjk within 48 hours the bug can be closed and the errata
pushed
Comment 10 Patrick C. F. Ernzer 2005-01-06 08:11:07 EST
nightly reported printed as expected.

please push the errata
Comment 12 John Flanagan 2005-04-28 11:38:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-055.html

Note You need to log in before you can comment on or make changes to this bug.