Bug 143283 - An alternative to the kernel-source RPM
Summary: An alternative to the kernel-source RPM
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-18 00:41 UTC by Joe Krahn
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 18:08:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Krahn 2004-12-18 00:41:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
While dropping kernel-source is a good thing, I propose adding a
feature to make setting up the source tree easier, such as a Makefile
in /usr/src. It could include targets like 'kernel_source' to get and
install current kernel sources, 'kernel_build' to make the kernel.

This should be a fairly simple addition, probably even easier than
writing a decent README on the subbject, but would help out a lot of
frustrated users.

Making a generalized Makefile is a bit difficult due to the various
combinations of kernel version + release strings for rpm/spec names.
It would be easiest if /usr/src/Makefile was owned by the kernel
package, maybe named
/usr/src/Makefile.linux-{KernelVersion}-{KernelRelease}.

Alternatively, maybe a perl-based 'kernel' command would be better,
because t handled very well by make. In this case, it could include
some extras, like initrd and grub.conf management.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /usr/src
2. make -f Makefile-2.6.9-1.681_FC3 kernel_source


Actual Results:  file not found; optionally followed by a lot of user
whining.

Additional info:

Maybe some day Bugzilla could make the Reproducability field optional
for Enhancement requests.

Comment 1 Dave Jones 2004-12-18 01:36:35 UTC
a gentoo-esque ports type system is something a bit more widespread
than kernel. reassigning to distribution, though I doubt this will
happen any time soon.

Comment 2 Bill Nottingham 2004-12-22 22:40:07 UTC
Hm, this would probably best be done as a wrapper around a fetcher for
source RPMs. Assigning yum-wards.

Comment 3 Rahul Sundaram 2005-06-19 03:03:08 UTC

yum download and yum-builddep in yum-utils seem to serve this purpose well

Yum-utils is currently in Fedora Extras repository which is enabled by default
in Fedora Core above above

This bug report should be closed


Note You need to log in before you can comment on or make changes to this bug.