Bug 143294 - SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0xb7515c6c>
Summary: SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0xb7515c6c>
Status: CLOSED DUPLICATE of bug 143293
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-18 08:06 UTC by Kevin Carter
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Carter 2004-12-18 08:06:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.2) Gecko/20040825 Camino/0.8.1

Description of problem:
Error occurs just before formatting and installing the packages:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot In Graphical Mode
2. Choose formatting options (I chose Automatic and remove all partitions)
3. Choose packages to Install (I chose Workstation)

    

Actual Results:  Error as reported above

Expected Results:  Drives formatted and Installation of packages began.

Additional info:

Comment 1 Kevin Carter 2004-12-18 08:06:44 UTC
Traceback *most recent call last):

 File "/usr/src/build/175969-i386/install//usr/lib/anaconda/gui.py",
line 1074, in handleRenderCallback
  self.currentWindow.renderCallback()
 File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/iw/progress_gui.py,"
line 242, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/src/build/475969-i386/install/usr/lib/anaconda/gui.py",
line 789, in nextClicked
  self.dispatch.gotoNext()
 File
"usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
  self.moveStep()
 File
"usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
  rc = apply(func, self.bindArgs(args))
 File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py",
line 554, in turnOnFilesystems
  thefsset.createLogicalVolumes(instPath)
 File "/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py",
line 1427, in createLogicalVolumes
  entry.device.setupDevice(chroot)
 File /usr/src/builg/475969-i386/install//usr/lib/anaconda/fsset.py",
line 1986, in setupDevice
  raise SystemError, "pvcreate failed for %s" % (volume,)

SystemError: pvcreate failed for <fsset.PartitionDevice instance at
0xb7515c6c>

Comment 2 Kevin Carter 2004-12-18 08:17:31 UTC
Seems it has something to do with the Anaconda GUI, doing the
installation in TEXT only mode seems to bypass this problem.

Comment 3 Sitsofe Wheeler 2004-12-19 22:05:10 UTC
This looks like a dup of bug 143293

Comment 4 Jeremy Katz 2004-12-20 18:12:09 UTC

*** This bug has been marked as a duplicate of 143293 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:07:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.