Bug 143296 - pbmtext segfaults when passed Greek characters as input.
pbmtext segfaults when passed Greek characters as input.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-18 04:51 EST by Dimitris
Modified: 2013-07-02 19:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 04:53:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed pbmtext.c without the bug for high ascii characters (file came from the author directly) (23.95 KB, text/plain)
2005-01-11 10:45 EST, Dimitris
no flags Details

  None (edit)
Description Dimitris 2004-12-18 04:51:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
In FC1 and FC2 we've been using pbmtext to generate images with Greek
text. Now with FC3, the same command segfaults.

This only happens if pbmtext is given Greek characters as input
(iso-8859-7 or UTF-8 character sets). It works fine with plain english.

For example:

$ pbmtext "ole" >text
$ pbmtext "ολε" >text
Segmentation fault
$

The first command has "ole" in iso-8859-1 characters and the second
command has them in iso-8859-7 characters.

PS:
i'm not sure if the Greek characters will be displayed properly in
bugzilla.


Version-Release number of selected component (if applicable):
10.25-2

How reproducible:
Always

Steps to Reproduce:
1. run pbmtext with Greek as input text.
2. pbmtext segfaults.

     


Actual Results:  Segmentation fault

Expected Results:  output is an image file with the Greek characters.

Additional info:

This command always worked fine in FC1 and FC2. Also, the output image
won't contain proper Greek characters by default because we haven't
loaded a Greek font file in bdf format. Though thats irrelevant with
this bug.
Comment 1 Jindrich Novy 2005-01-10 11:37:04 EST
Hello Dimitris, maybe the problem was in the old libpng where I saw
the segfaults, does it work for you if you upgrade to libpng-1.2.8?

http://sunsite.mff.cuni.cz/pub/fedora/development/i386/Fedora/RPMS/libpng-1.2.8-1.i386.rpm

I'm unable to reproduce this bug any more after the upgrade.
Comment 2 Dimitris 2005-01-11 10:43:17 EST
I've contacted the author of the package and here is his reply:

"There's a bug in the latest release of Netpbm (10.25) that causes
that crash
whenever a character of the input text has an ASCII code greater than
127."

He also said that version 10.18.17 does not have the bug, and that the
next release due out this month (maybe its already out?) will have the
bug fixed.

I dont think the problem is with libpng. Maybe you updated your netpbm
package at some point?
Comment 3 Dimitris 2005-01-11 10:45:27 EST
Created attachment 109614 [details]
Fixed pbmtext.c without the bug for high ascii characters (file came from the author directly)
Comment 4 Jindrich Novy 2005-01-12 04:53:17 EST
Dimitris, yes, I build the netpbm-10.26 recently and it resolves your
problem. Please update to it from:

http://sunsite.mff.cuni.cz/pub/fedora/development/i386/Fedora/RPMS/netpbm-10.26-1.i386.rpm

The pbmtext.c source you attached is identical to the one in this release.

Thanks for the bugreport.

Note You need to log in before you can comment on or make changes to this bug.