Bug 143297 - anaconda exits with "TypeError" in findpackageset.py
anaconda exits with "TypeError" in findpackageset.py
Status: CLOSED DUPLICATE of bug 138485
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-18 05:24 EST by Jost Langner
Modified: 2017-04-17 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-18 08:48:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Langner 2004-12-18 05:24:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.3)
Gecko/20041027 Firefox/1.0RC1

Description of problem:
Situation: upgrade from fc2 to fc3 by CD. First CD inserted. Media was
successfully checked, means: doesn't have any errors on it.

anaconda starts upgrade until the step "find installed packages" (or
so), then displays an error message (see below) and exits.

(If helpful, I can provide the complete anaconda dump file
"anacdump.txt", but this is more than 1MB, so for this step I send
only the first lines of error messages but not the dump.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. insert first fc3 CD
2. reboot system
3. follow the installation procedure until error occurs.
    

Additional info:

Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/upgrade.py",
line 396, in upgradeFindPackages
    instPath)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/findpackageset.py",
line 149, in findpackageset
    val =
rpm.labelCompare(oevr,(epoch,h[rpm.RPMTAG_VERSION],h[rpm.RPMTAG_RELEASE]))
TypeError: argument 1, item 0 must be string or None, not long
Comment 1 Paul Nasrat 2004-12-18 08:48:45 EST
Use the updates image here:

http://people.redhat.com/pnasrat/updates-138485.img

Update instructions in:

http://rhlinux.redhat.com/anaconda/updatedisks.html

*** This bug has been marked as a duplicate of 138485 ***

Note You need to log in before you can comment on or make changes to this bug.